%global _empty_manifest_terminate_build 0
Name: python-autostack
Version: 1.2.1
Release: 1
Summary: Automatically detect python errors and search Stack Overflow.
License: MIT License
URL: https://github.com/elijahsawyers/autostack
Source0: https://mirrors.aliyun.com/pypi/web/packages/a8/ba/aaf0f9a707ba2a832dd128cbdd094afcdd4002d3edcae898a5a96e9431f0/autostack-1.2.1.tar.gz
BuildArch: noarch
%description

autostack is a command-line debugging tool for Python projects that automatically displays Stack Overflow answers for thrown errors.
What is the first thing you do when a confusing error message is displayed in your terminal window? You search for an answer on Stack Overflow, of course! With autostack, you no longer have to search for answers on Stack Overflow, they are found for you. Gone are the days of scouring the internet for hours to find an answer to your development questions! autostack is here to automate the debugging process and in turn, expedite Python project development.
## Table of Contents
* [Installation](#Installation)
* [Usage](#Usage)
* [Demo](#Demo)
* [Contributing](#Contributing)
* [License](#License)
* [Show your support](#Show-your-support)
* [Authors](#Authors)
## Installation
**1. Clone the repo and use the install script.**
Clone the repo.
```sh
git clone https://github.com/autostack-team/autostack.git
```
Navigate to the project directory, and run the install bash script.
```sh
cd /path/to/project/
chmod +x install.sh
./install.sh
```
**2. Or just use pip to install.**
```sh
pip3 install autostack
```
## Usage
In one terminal window, execute "autostack capture" which will capture all errors in the terminal. You can run this command in as many terminal windows as you'd like.
```sh
autostack capture
```
In another terminal window, execute "autostack display" to display Stack Overflow posts for all captured errors.
```sh
autostack display
```
To stop running autostack, use the exit command in the terminals that executed "autostack capture". This automatically stops the terminal window displaying Stack Overflow posts for captured errors.
```sh
exit
```
## Demo
Checkout the demo below!
## Contributing
For information on how to get started contributing to autostack, see the [contributing guidlines](https://github.com/autostack-team/autostack/blob/master/CONTRIBUTING.md).
## License
This project is licensed under the MIT License - see the [LICENSE](LICENSE) file for details.
## Show your support
Give a ⭐️ if autostack has helped you!
## Authors
* [Elijah Sawyers](https://github.com/elijahsawyers)
* [Benjamin Sanders](https://github.com/BenOSanders)
* [Caleb Werth](https://github.com/cwerth1)
%package -n python3-autostack
Summary: Automatically detect python errors and search Stack Overflow.
Provides: python-autostack
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-autostack

autostack is a command-line debugging tool for Python projects that automatically displays Stack Overflow answers for thrown errors.
What is the first thing you do when a confusing error message is displayed in your terminal window? You search for an answer on Stack Overflow, of course! With autostack, you no longer have to search for answers on Stack Overflow, they are found for you. Gone are the days of scouring the internet for hours to find an answer to your development questions! autostack is here to automate the debugging process and in turn, expedite Python project development.
## Table of Contents
* [Installation](#Installation)
* [Usage](#Usage)
* [Demo](#Demo)
* [Contributing](#Contributing)
* [License](#License)
* [Show your support](#Show-your-support)
* [Authors](#Authors)
## Installation
**1. Clone the repo and use the install script.**
Clone the repo.
```sh
git clone https://github.com/autostack-team/autostack.git
```
Navigate to the project directory, and run the install bash script.
```sh
cd /path/to/project/
chmod +x install.sh
./install.sh
```
**2. Or just use pip to install.**
```sh
pip3 install autostack
```
## Usage
In one terminal window, execute "autostack capture" which will capture all errors in the terminal. You can run this command in as many terminal windows as you'd like.
```sh
autostack capture
```
In another terminal window, execute "autostack display" to display Stack Overflow posts for all captured errors.
```sh
autostack display
```
To stop running autostack, use the exit command in the terminals that executed "autostack capture". This automatically stops the terminal window displaying Stack Overflow posts for captured errors.
```sh
exit
```
## Demo
Checkout the demo below!
## Contributing
For information on how to get started contributing to autostack, see the [contributing guidlines](https://github.com/autostack-team/autostack/blob/master/CONTRIBUTING.md).
## License
This project is licensed under the MIT License - see the [LICENSE](LICENSE) file for details.
## Show your support
Give a ⭐️ if autostack has helped you!
## Authors
* [Elijah Sawyers](https://github.com/elijahsawyers)
* [Benjamin Sanders](https://github.com/BenOSanders)
* [Caleb Werth](https://github.com/cwerth1)
%package help
Summary: Development documents and examples for autostack
Provides: python3-autostack-doc
%description help

autostack is a command-line debugging tool for Python projects that automatically displays Stack Overflow answers for thrown errors.
What is the first thing you do when a confusing error message is displayed in your terminal window? You search for an answer on Stack Overflow, of course! With autostack, you no longer have to search for answers on Stack Overflow, they are found for you. Gone are the days of scouring the internet for hours to find an answer to your development questions! autostack is here to automate the debugging process and in turn, expedite Python project development.
## Table of Contents
* [Installation](#Installation)
* [Usage](#Usage)
* [Demo](#Demo)
* [Contributing](#Contributing)
* [License](#License)
* [Show your support](#Show-your-support)
* [Authors](#Authors)
## Installation
**1. Clone the repo and use the install script.**
Clone the repo.
```sh
git clone https://github.com/autostack-team/autostack.git
```
Navigate to the project directory, and run the install bash script.
```sh
cd /path/to/project/
chmod +x install.sh
./install.sh
```
**2. Or just use pip to install.**
```sh
pip3 install autostack
```
## Usage
In one terminal window, execute "autostack capture" which will capture all errors in the terminal. You can run this command in as many terminal windows as you'd like.
```sh
autostack capture
```
In another terminal window, execute "autostack display" to display Stack Overflow posts for all captured errors.
```sh
autostack display
```
To stop running autostack, use the exit command in the terminals that executed "autostack capture". This automatically stops the terminal window displaying Stack Overflow posts for captured errors.
```sh
exit
```
## Demo
Checkout the demo below!
## Contributing
For information on how to get started contributing to autostack, see the [contributing guidlines](https://github.com/autostack-team/autostack/blob/master/CONTRIBUTING.md).
## License
This project is licensed under the MIT License - see the [LICENSE](LICENSE) file for details.
## Show your support
Give a ⭐️ if autostack has helped you!
## Authors
* [Elijah Sawyers](https://github.com/elijahsawyers)
* [Benjamin Sanders](https://github.com/BenOSanders)
* [Caleb Werth](https://github.com/cwerth1)
%prep
%autosetup -n autostack-1.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-autostack -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.2.1-1
- Package Spec generated