%global _empty_manifest_terminate_build 0
Name: python-biolib
Version: 0.1.9
Release: 1
Summary: Package for common tasks in bioinformatics.
License: GPL3
URL: http://pypi.python.org/pypi/biolib/
Source0: https://mirrors.aliyun.com/pypi/web/packages/ba/74/4c662152fe00936df4ef1f6cc3ef75e13984d5346a7692e095369a53814c/biolib-0.1.9.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-matplotlib
Requires: python3-scipy
%description
# biolib
[This library is in active development and not currently recommended for public use.]
[](https://pypi.python.org/pypi/biolib)
[](https://anaconda.org/bioconda/biolib)
Biolib is a python package for common tasks in bioinformatics.
## Announcements
* Ported to Python 3 starting with version 0.1.0
## Install
The simplest way to install this package is through pip:
```shell
python -m pip install biolib
```
## Cite
If you find this package useful, please cite this git repository https://github.com/dparks1134/biolib.
## Copyright
Copyright © 2015 Donovan Parks. See LICENSE for further details.
%package -n python3-biolib
Summary: Package for common tasks in bioinformatics.
Provides: python-biolib
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-biolib
# biolib
[This library is in active development and not currently recommended for public use.]
[](https://pypi.python.org/pypi/biolib)
[](https://anaconda.org/bioconda/biolib)
Biolib is a python package for common tasks in bioinformatics.
## Announcements
* Ported to Python 3 starting with version 0.1.0
## Install
The simplest way to install this package is through pip:
```shell
python -m pip install biolib
```
## Cite
If you find this package useful, please cite this git repository https://github.com/dparks1134/biolib.
## Copyright
Copyright © 2015 Donovan Parks. See LICENSE for further details.
%package help
Summary: Development documents and examples for biolib
Provides: python3-biolib-doc
%description help
# biolib
[This library is in active development and not currently recommended for public use.]
[](https://pypi.python.org/pypi/biolib)
[](https://anaconda.org/bioconda/biolib)
Biolib is a python package for common tasks in bioinformatics.
## Announcements
* Ported to Python 3 starting with version 0.1.0
## Install
The simplest way to install this package is through pip:
```shell
python -m pip install biolib
```
## Cite
If you find this package useful, please cite this git repository https://github.com/dparks1134/biolib.
## Copyright
Copyright © 2015 Donovan Parks. See LICENSE for further details.
%prep
%autosetup -n biolib-0.1.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-biolib -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.9-1
- Package Spec generated