%global _empty_manifest_terminate_build 0
Name: python-pyoracle-forms
Version: 0.4.1
Release: 1
Summary: Python wrapper of the Oracle Forms API
License: MIT License
URL: https://github.com/LatvianPython/pyoracle_forms
Source0: https://mirrors.aliyun.com/pypi/web/packages/36/ac/b68aecb4fb4a4225536a54b8b8ddd46e7a982c1bedd93f439f360fad4dce/pyoracle_forms-0.4.1.tar.gz
BuildArch: noarch
%description
##################################################################
pyoracle_forms
##################################################################
.. image:: https://raw.githubusercontent.com/LatvianPython/pyoracle_forms/master/media/coverage.svg?sanitize=true
:target: https://github.com/LatvianPython/pyoracle_forms
:alt: Coverage
.. image:: https://img.shields.io/pypi/pyversions/pyoracle_forms
:target: https://www.python.org/downloads/
:alt: Python
.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
:target: https://github.com/psf/black
:alt: Black
.. image:: https://img.shields.io/pypi/v/pyoracle_forms
:target: https://pypi.org/project/pyoracle-forms/
:alt: PyPI
.. image:: https://readthedocs.org/projects/pyoracle-forms/badge/?version=latest
:target: https://pyoracle-forms.readthedocs.io/en/latest/?badge=latest
:alt: Read the Docs
.. image:: https://img.shields.io/codeclimate/maintainability/LatvianPython/pyoracle_forms
:target: https://codeclimate.com/github/LatvianPython/pyoracle_forms
:alt: Code Climate maintainability
.. image:: http://www.mypy-lang.org/static/mypy_badge.svg
:target: http://mypy-lang.org/
:alt: Checked with mypy
Wraps the Oracle Forms API under Python, so that you can write scripts to
make programmatic changes to Oracle Forms .fmb files with ease.
##################################################################
Installation and usage
##################################################################
******************************************************************
Installation
******************************************************************
The package can be installed from PyPI with ``pip install pyoracle-forms``
******************************************************************
Usage
******************************************************************
.. code-block:: python
from pyoracle_forms import Module, initialize_context
initialize_context(version="12c", encoding="utf-8")
with Module.load("./your_form.fmb") as module:
for data_block in module.data_blocks:
for item in data_block.items:
item.font_name = "Comic Sans MS"
module.save()
Best used with an interactive environment, such as Jupyter Notebook, as you get better autocomplete
there due to attributes getting determined dynamically.
You also need access to successfully installed version of Oracle Forms, otherwise the scripts won't work,
as this solution depends on the Oracle Forms API.
******************************************************************
Documentation
******************************************************************
More detailed documentation is available on `Read the Docs `_
%package -n python3-pyoracle-forms
Summary: Python wrapper of the Oracle Forms API
Provides: python-pyoracle-forms
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyoracle-forms
##################################################################
pyoracle_forms
##################################################################
.. image:: https://raw.githubusercontent.com/LatvianPython/pyoracle_forms/master/media/coverage.svg?sanitize=true
:target: https://github.com/LatvianPython/pyoracle_forms
:alt: Coverage
.. image:: https://img.shields.io/pypi/pyversions/pyoracle_forms
:target: https://www.python.org/downloads/
:alt: Python
.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
:target: https://github.com/psf/black
:alt: Black
.. image:: https://img.shields.io/pypi/v/pyoracle_forms
:target: https://pypi.org/project/pyoracle-forms/
:alt: PyPI
.. image:: https://readthedocs.org/projects/pyoracle-forms/badge/?version=latest
:target: https://pyoracle-forms.readthedocs.io/en/latest/?badge=latest
:alt: Read the Docs
.. image:: https://img.shields.io/codeclimate/maintainability/LatvianPython/pyoracle_forms
:target: https://codeclimate.com/github/LatvianPython/pyoracle_forms
:alt: Code Climate maintainability
.. image:: http://www.mypy-lang.org/static/mypy_badge.svg
:target: http://mypy-lang.org/
:alt: Checked with mypy
Wraps the Oracle Forms API under Python, so that you can write scripts to
make programmatic changes to Oracle Forms .fmb files with ease.
##################################################################
Installation and usage
##################################################################
******************************************************************
Installation
******************************************************************
The package can be installed from PyPI with ``pip install pyoracle-forms``
******************************************************************
Usage
******************************************************************
.. code-block:: python
from pyoracle_forms import Module, initialize_context
initialize_context(version="12c", encoding="utf-8")
with Module.load("./your_form.fmb") as module:
for data_block in module.data_blocks:
for item in data_block.items:
item.font_name = "Comic Sans MS"
module.save()
Best used with an interactive environment, such as Jupyter Notebook, as you get better autocomplete
there due to attributes getting determined dynamically.
You also need access to successfully installed version of Oracle Forms, otherwise the scripts won't work,
as this solution depends on the Oracle Forms API.
******************************************************************
Documentation
******************************************************************
More detailed documentation is available on `Read the Docs `_
%package help
Summary: Development documents and examples for pyoracle-forms
Provides: python3-pyoracle-forms-doc
%description help
##################################################################
pyoracle_forms
##################################################################
.. image:: https://raw.githubusercontent.com/LatvianPython/pyoracle_forms/master/media/coverage.svg?sanitize=true
:target: https://github.com/LatvianPython/pyoracle_forms
:alt: Coverage
.. image:: https://img.shields.io/pypi/pyversions/pyoracle_forms
:target: https://www.python.org/downloads/
:alt: Python
.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
:target: https://github.com/psf/black
:alt: Black
.. image:: https://img.shields.io/pypi/v/pyoracle_forms
:target: https://pypi.org/project/pyoracle-forms/
:alt: PyPI
.. image:: https://readthedocs.org/projects/pyoracle-forms/badge/?version=latest
:target: https://pyoracle-forms.readthedocs.io/en/latest/?badge=latest
:alt: Read the Docs
.. image:: https://img.shields.io/codeclimate/maintainability/LatvianPython/pyoracle_forms
:target: https://codeclimate.com/github/LatvianPython/pyoracle_forms
:alt: Code Climate maintainability
.. image:: http://www.mypy-lang.org/static/mypy_badge.svg
:target: http://mypy-lang.org/
:alt: Checked with mypy
Wraps the Oracle Forms API under Python, so that you can write scripts to
make programmatic changes to Oracle Forms .fmb files with ease.
##################################################################
Installation and usage
##################################################################
******************************************************************
Installation
******************************************************************
The package can be installed from PyPI with ``pip install pyoracle-forms``
******************************************************************
Usage
******************************************************************
.. code-block:: python
from pyoracle_forms import Module, initialize_context
initialize_context(version="12c", encoding="utf-8")
with Module.load("./your_form.fmb") as module:
for data_block in module.data_blocks:
for item in data_block.items:
item.font_name = "Comic Sans MS"
module.save()
Best used with an interactive environment, such as Jupyter Notebook, as you get better autocomplete
there due to attributes getting determined dynamically.
You also need access to successfully installed version of Oracle Forms, otherwise the scripts won't work,
as this solution depends on the Oracle Forms API.
******************************************************************
Documentation
******************************************************************
More detailed documentation is available on `Read the Docs `_
%prep
%autosetup -n pyoracle_forms-0.4.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyoracle-forms -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.4.1-1
- Package Spec generated