%global _empty_manifest_terminate_build 0
Name: python-molten
Version: 1.0.2
Release: 1
Summary: A minimal, extensible, fast and productive API framework.
License: GNU Lesser General Public License v3 or later (LGPLv3+)
URL: https://pypi.org/project/molten/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/81/3e/f6f39d34585c06e9a7c42b80016ba04ea3689aba61fbe68849a952207141/molten-1.0.2.tar.gz
BuildArch: noarch
Requires: python3-typing-extensions
Requires: python3-typing-inspect
Requires: python3-typing-extensions
Requires: python3-typing-inspect
Requires: python3-typing-extensions
Requires: python3-typing-inspect
Requires: python3-alabaster
Requires: python3-sphinx
Requires: python3-sphinxcontrib-napoleon
Requires: python3-flake8
Requires: python3-flake8-bugbear
Requires: python3-flake8-quotes
Requires: python3-isort
Requires: python3-mypy
Requires: python3-bumpversion
Requires: python3-dramatiq[rabbitmq]
Requires: python3-gevent
Requires: python3-gunicorn
Requires: python3-jinja2
Requires: python3-msgpack
Requires: python3-prometheus-client
Requires: python3-sqlalchemy
Requires: python3-toml
Requires: python3-wsgicors
Requires: python3-pytest
%description
# molten
[![CI](https://github.com/Bogdanp/molten/workflows/CI/badge.svg)](https://github.com/Bogdanp/molten/actions?query=workflow%3ACI)
[![PyPI version](https://badge.fury.io/py/molten.svg)](https://badge.fury.io/py/molten)
[![Documentation](https://img.shields.io/badge/doc-latest-brightgreen.svg)](https://moltenframework.com)
[![Reddit](https://img.shields.io/badge/discuss-online-orange.svg)](https://www.reddit.com/r/moltenframework/)
*A minimal, extensible, fast and productive API framework for Python 3.*
**Changelog**: https://moltenframework.com/changelog.html
**Community**: https://www.reddit.com/r/moltenframework/
**Documentation**: https://moltenframework.com
## Installation
pip install molten
## Quickstart
Check out the [examples] folder to get a taste of the framework or
read the [user guide]!
## License
molten is licensed under the LGPL. Please see [COPYING] and
[COPYING.LESSER] for licensing details.
[COPYING.LESSER]: https://github.com/Bogdanp/molten/blob/master/COPYING.LESSER
[COPYING]: https://github.com/Bogdanp/molten/blob/master/COPYING
[examples]: https://github.com/Bogdanp/molten/blob/master/examples
[user guide]: https://moltenframework.com/guide.html
%package -n python3-molten
Summary: A minimal, extensible, fast and productive API framework.
Provides: python-molten
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-molten
# molten
[![CI](https://github.com/Bogdanp/molten/workflows/CI/badge.svg)](https://github.com/Bogdanp/molten/actions?query=workflow%3ACI)
[![PyPI version](https://badge.fury.io/py/molten.svg)](https://badge.fury.io/py/molten)
[![Documentation](https://img.shields.io/badge/doc-latest-brightgreen.svg)](https://moltenframework.com)
[![Reddit](https://img.shields.io/badge/discuss-online-orange.svg)](https://www.reddit.com/r/moltenframework/)
*A minimal, extensible, fast and productive API framework for Python 3.*
**Changelog**: https://moltenframework.com/changelog.html
**Community**: https://www.reddit.com/r/moltenframework/
**Documentation**: https://moltenframework.com
## Installation
pip install molten
## Quickstart
Check out the [examples] folder to get a taste of the framework or
read the [user guide]!
## License
molten is licensed under the LGPL. Please see [COPYING] and
[COPYING.LESSER] for licensing details.
[COPYING.LESSER]: https://github.com/Bogdanp/molten/blob/master/COPYING.LESSER
[COPYING]: https://github.com/Bogdanp/molten/blob/master/COPYING
[examples]: https://github.com/Bogdanp/molten/blob/master/examples
[user guide]: https://moltenframework.com/guide.html
%package help
Summary: Development documents and examples for molten
Provides: python3-molten-doc
%description help
# molten
[![CI](https://github.com/Bogdanp/molten/workflows/CI/badge.svg)](https://github.com/Bogdanp/molten/actions?query=workflow%3ACI)
[![PyPI version](https://badge.fury.io/py/molten.svg)](https://badge.fury.io/py/molten)
[![Documentation](https://img.shields.io/badge/doc-latest-brightgreen.svg)](https://moltenframework.com)
[![Reddit](https://img.shields.io/badge/discuss-online-orange.svg)](https://www.reddit.com/r/moltenframework/)
*A minimal, extensible, fast and productive API framework for Python 3.*
**Changelog**: https://moltenframework.com/changelog.html
**Community**: https://www.reddit.com/r/moltenframework/
**Documentation**: https://moltenframework.com
## Installation
pip install molten
## Quickstart
Check out the [examples] folder to get a taste of the framework or
read the [user guide]!
## License
molten is licensed under the LGPL. Please see [COPYING] and
[COPYING.LESSER] for licensing details.
[COPYING.LESSER]: https://github.com/Bogdanp/molten/blob/master/COPYING.LESSER
[COPYING]: https://github.com/Bogdanp/molten/blob/master/COPYING
[examples]: https://github.com/Bogdanp/molten/blob/master/examples
[user guide]: https://moltenframework.com/guide.html
%prep
%autosetup -n molten-1.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-molten -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 1.0.2-1
- Package Spec generated