%global _empty_manifest_terminate_build 0
Name: python-pymssql
Version: 2.2.7
Release: 1
Summary: DB-API interface to Microsoft SQL Server for Python. (new Cython-based version)
License: LGPL
URL: https://pypi.org/project/pymssql/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/64/68/c1ba0fabf98ebe9d22afc23c6b6803553b28911ed36bb53b8be93feb2446/pymssql-2.2.7.tar.gz
%description
A simple database interface for `Python`_ that builds on top of `FreeTDS`_ to
provide a Python DB-API (`PEP-249`_) interface to `Microsoft SQL Server`_.
Detailed information on pymssql is available on the website:
`pymssql.readthedocs.io `_
New development is happening on GitHub at:
`github.com/pymssql/pymssql `_
There is a Google Group for discussion at:
`groups.google.com `_
%package -n python3-pymssql
Summary: DB-API interface to Microsoft SQL Server for Python. (new Cython-based version)
Provides: python-pymssql
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-pymssql
A simple database interface for `Python`_ that builds on top of `FreeTDS`_ to
provide a Python DB-API (`PEP-249`_) interface to `Microsoft SQL Server`_.
Detailed information on pymssql is available on the website:
`pymssql.readthedocs.io `_
New development is happening on GitHub at:
`github.com/pymssql/pymssql `_
There is a Google Group for discussion at:
`groups.google.com `_
%package help
Summary: Development documents and examples for pymssql
Provides: python3-pymssql-doc
%description help
A simple database interface for `Python`_ that builds on top of `FreeTDS`_ to
provide a Python DB-API (`PEP-249`_) interface to `Microsoft SQL Server`_.
Detailed information on pymssql is available on the website:
`pymssql.readthedocs.io `_
New development is happening on GitHub at:
`github.com/pymssql/pymssql `_
There is a Google Group for discussion at:
`groups.google.com `_
%prep
%autosetup -n pymssql-2.2.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pymssql -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 2.2.7-1
- Package Spec generated