%global _empty_manifest_terminate_build 0
Name: python-pytest-vcr
Version: 1.0.2
Release: 1
Summary: Plugin for managing VCR.py cassettes
License: MIT
URL: https://github.com/ktosiek/pytest-vcr
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1a/60/104c619483c1a42775d3f8b27293f1ecfc0728014874d065e68cb9702d49/pytest-vcr-1.0.2.tar.gz
BuildArch: noarch
Requires: python3-pytest
Requires: python3-vcrpy
%description
Install the plugin:
pip install pytest-vcr
Annotate your tests:
@pytest.mark.vcr()
def test_iana():
response = urlopen('http://www.iana.org/domains/reserved').read()
assert b'Example domains' in response
And that's it!
A new file ``cassettes/test_iana.yaml`` will be created next to your test file on the first run.
This file should be committed to a VCS.
For more examples and configuration options see the `documention on ReadTheDocs `_.
%package -n python3-pytest-vcr
Summary: Plugin for managing VCR.py cassettes
Provides: python-pytest-vcr
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pytest-vcr
Install the plugin:
pip install pytest-vcr
Annotate your tests:
@pytest.mark.vcr()
def test_iana():
response = urlopen('http://www.iana.org/domains/reserved').read()
assert b'Example domains' in response
And that's it!
A new file ``cassettes/test_iana.yaml`` will be created next to your test file on the first run.
This file should be committed to a VCS.
For more examples and configuration options see the `documention on ReadTheDocs `_.
%package help
Summary: Development documents and examples for pytest-vcr
Provides: python3-pytest-vcr-doc
%description help
Install the plugin:
pip install pytest-vcr
Annotate your tests:
@pytest.mark.vcr()
def test_iana():
response = urlopen('http://www.iana.org/domains/reserved').read()
assert b'Example domains' in response
And that's it!
A new file ``cassettes/test_iana.yaml`` will be created next to your test file on the first run.
This file should be committed to a VCS.
For more examples and configuration options see the `documention on ReadTheDocs `_.
%prep
%autosetup -n pytest-vcr-1.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pytest-vcr -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 1.0.2-1
- Package Spec generated