%global _empty_manifest_terminate_build 0
Name: python-stompest
Version: 2.3.0
Release: 1
Summary: STOMP library for Python including a synchronous client.
License: Apache License 2.0
URL: https://github.com/nikipore/stompest
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6f/eb/29c1800f821372fd4b0f92c5185970147d73cf72dc17e43c88cf4e9d57f3/stompest-2.3.0.tar.gz
BuildArch: noarch
%description
`stompest `_ is a full-featured `STOMP `_ `1.0 `_, `1.1 `_, and `1.2 `_ implementation for Python 2.7 and Python 3 (versions 3.3 and higher), with optional TLS/SSL support.
The STOMP client in this package is dead simple: It does not assume anything about your concurrency model (thread vs process) or force you to use it any particular way. It gets out of your way and lets you do what you want. The package also consists of a generic set of components each of which you may use independently to roll your own STOMP client:
* a wire-level STOMP frame parser and compiler,
* a faithful implementation of the syntax of the STOMP protocol with a simple stateless function API,
* a generic implementation of the STOMP session state semantics, such as protocol version negotiation at connect time, transaction and subscription handling (including a generic subscription replay scheme which may be used to reconstruct the session's subscription state after a forced disconnect),
* and a `failover transport `_ URI scheme akin to the one used in ActiveMQ.
This package is thoroughly unit tested and production hardened for the functionality used by the current maintainer and by `Mozes `_ -- persistent queueing on `ActiveMQ `_. Minor enhancements may be required to use this STOMP adapter with other brokers.
%package -n python3-stompest
Summary: STOMP library for Python including a synchronous client.
Provides: python-stompest
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-stompest
`stompest `_ is a full-featured `STOMP `_ `1.0 `_, `1.1 `_, and `1.2 `_ implementation for Python 2.7 and Python 3 (versions 3.3 and higher), with optional TLS/SSL support.
The STOMP client in this package is dead simple: It does not assume anything about your concurrency model (thread vs process) or force you to use it any particular way. It gets out of your way and lets you do what you want. The package also consists of a generic set of components each of which you may use independently to roll your own STOMP client:
* a wire-level STOMP frame parser and compiler,
* a faithful implementation of the syntax of the STOMP protocol with a simple stateless function API,
* a generic implementation of the STOMP session state semantics, such as protocol version negotiation at connect time, transaction and subscription handling (including a generic subscription replay scheme which may be used to reconstruct the session's subscription state after a forced disconnect),
* and a `failover transport `_ URI scheme akin to the one used in ActiveMQ.
This package is thoroughly unit tested and production hardened for the functionality used by the current maintainer and by `Mozes `_ -- persistent queueing on `ActiveMQ `_. Minor enhancements may be required to use this STOMP adapter with other brokers.
%package help
Summary: Development documents and examples for stompest
Provides: python3-stompest-doc
%description help
`stompest `_ is a full-featured `STOMP `_ `1.0 `_, `1.1 `_, and `1.2 `_ implementation for Python 2.7 and Python 3 (versions 3.3 and higher), with optional TLS/SSL support.
The STOMP client in this package is dead simple: It does not assume anything about your concurrency model (thread vs process) or force you to use it any particular way. It gets out of your way and lets you do what you want. The package also consists of a generic set of components each of which you may use independently to roll your own STOMP client:
* a wire-level STOMP frame parser and compiler,
* a faithful implementation of the syntax of the STOMP protocol with a simple stateless function API,
* a generic implementation of the STOMP session state semantics, such as protocol version negotiation at connect time, transaction and subscription handling (including a generic subscription replay scheme which may be used to reconstruct the session's subscription state after a forced disconnect),
* and a `failover transport `_ URI scheme akin to the one used in ActiveMQ.
This package is thoroughly unit tested and production hardened for the functionality used by the current maintainer and by `Mozes `_ -- persistent queueing on `ActiveMQ `_. Minor enhancements may be required to use this STOMP adapter with other brokers.
%prep
%autosetup -n stompest-2.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-stompest -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 2.3.0-1
- Package Spec generated