%global _empty_manifest_terminate_build 0
Name: python-treq
Version: 22.2.0
Release: 1
Summary: High-level Twisted HTTP Client API
License: MIT/X
URL: https://github.com/twisted/treq
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cd/c8/b68ab17d994133baf6edbcb5551ba81e1494bdc6d5e21a9d4f3bc4315140/treq-22.2.0.tar.gz
BuildArch: noarch
Requires: python3-incremental
Requires: python3-requests
Requires: python3-hyperlink
Requires: python3-Twisted[tls]
Requires: python3-attrs
Requires: python3-pep8
Requires: python3-pyflakes
Requires: python3-httpbin
Requires: python3-sphinx
%description
|pypi|_
|calver|_
|coverage|_
|documentation|_
``treq`` is an HTTP library inspired by
`requests `_ but written on top of
`Twisted `_'s
`Agents `_.
It provides a simple, higher level API for making HTTP requests when
using Twisted.
>>> import treq
>>> def done(response):
>>> treq.get("https://github.com").addCallback(done)
>>> from twisted.internet import reactor
>>> reactor.run()
200
For more info `read the docs `_.
%package -n python3-treq
Summary: High-level Twisted HTTP Client API
Provides: python-treq
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-treq
|pypi|_
|calver|_
|coverage|_
|documentation|_
``treq`` is an HTTP library inspired by
`requests `_ but written on top of
`Twisted `_'s
`Agents `_.
It provides a simple, higher level API for making HTTP requests when
using Twisted.
>>> import treq
>>> def done(response):
>>> treq.get("https://github.com").addCallback(done)
>>> from twisted.internet import reactor
>>> reactor.run()
200
For more info `read the docs `_.
%package help
Summary: Development documents and examples for treq
Provides: python3-treq-doc
%description help
|pypi|_
|calver|_
|coverage|_
|documentation|_
``treq`` is an HTTP library inspired by
`requests `_ but written on top of
`Twisted `_'s
`Agents `_.
It provides a simple, higher level API for making HTTP requests when
using Twisted.
>>> import treq
>>> def done(response):
>>> treq.get("https://github.com").addCallback(done)
>>> from twisted.internet import reactor
>>> reactor.run()
200
For more info `read the docs `_.
%prep
%autosetup -n treq-22.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-treq -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 22.2.0-1
- Package Spec generated