%global _empty_manifest_terminate_build 0
Name: python-Twiggy
Version: 0.5.1
Release: 1
Summary: a Pythonic logger
License: BSD
URL: https://github.com/wearpants/twiggy/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6e/81/6e2e2ee0e90df68ce1e8aec6fe147563dfcadbab3072f57f71bf42433cb2/Twiggy-0.5.1.tar.gz
BuildArch: noarch
Requires: python3-six
%description
Twiggy is a Pythonic logger.
>>> from twiggy import quick_setup, log
>>> quick_setup()
>>> log.name('frank') \
'sunny',
who='world')
INFO:frank:number=42:hello world, it's a sunny day
You should use Twiggy because it is awesome. For more information, read the
`documentation `_ or `see this blog post
`_.
%package -n python3-Twiggy
Summary: a Pythonic logger
Provides: python-Twiggy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Twiggy
Twiggy is a Pythonic logger.
>>> from twiggy import quick_setup, log
>>> quick_setup()
>>> log.name('frank') \
'sunny',
who='world')
INFO:frank:number=42:hello world, it's a sunny day
You should use Twiggy because it is awesome. For more information, read the
`documentation `_ or `see this blog post
`_.
%package help
Summary: Development documents and examples for Twiggy
Provides: python3-Twiggy-doc
%description help
Twiggy is a Pythonic logger.
>>> from twiggy import quick_setup, log
>>> quick_setup()
>>> log.name('frank') \
'sunny',
who='world')
INFO:frank:number=42:hello world, it's a sunny day
You should use Twiggy because it is awesome. For more information, read the
`documentation `_ or `see this blog post
`_.
%prep
%autosetup -n Twiggy-0.5.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Twiggy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 0.5.1-1
- Package Spec generated