%global _empty_manifest_terminate_build 0
Name: python-wsaccel
Version: 0.6.4
Release: 1
Summary: Accelerator for ws4py and AutobahnPython
License: Apache
URL: https://github.com/methane/wsaccel
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/77/0b/a44df15382a76b6768184630d483b8363d65b9f70d1aacf76153d496bbb9/wsaccel-0.6.4.tar.gz
%description
**NOTE: AutobahnPython and ws4py are not actively maintained. So I will stop this project too.
Please migrate to `Tornado `_ or
`websockets `_.**
WSAccell is WebSocket accelerator for `AutobahnPython `_,
and `ws4py `_.
WSAccell replaces per-byte process in them with Cython version.
AutobahnPython beginning with version 0.6 automatically uses WSAccell if available.
Otherwise you can run-time patch supported WebSocket libraries using:
import wsaccel
wsaccel.patch_autobahn() # for autobahn.
wsaccel.patch_ws4py() # for ws4py.
%package -n python3-wsaccel
Summary: Accelerator for ws4py and AutobahnPython
Provides: python-wsaccel
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-wsaccel
**NOTE: AutobahnPython and ws4py are not actively maintained. So I will stop this project too.
Please migrate to `Tornado `_ or
`websockets `_.**
WSAccell is WebSocket accelerator for `AutobahnPython `_,
and `ws4py `_.
WSAccell replaces per-byte process in them with Cython version.
AutobahnPython beginning with version 0.6 automatically uses WSAccell if available.
Otherwise you can run-time patch supported WebSocket libraries using:
import wsaccel
wsaccel.patch_autobahn() # for autobahn.
wsaccel.patch_ws4py() # for ws4py.
%package help
Summary: Development documents and examples for wsaccel
Provides: python3-wsaccel-doc
%description help
**NOTE: AutobahnPython and ws4py are not actively maintained. So I will stop this project too.
Please migrate to `Tornado `_ or
`websockets `_.**
WSAccell is WebSocket accelerator for `AutobahnPython `_,
and `ws4py `_.
WSAccell replaces per-byte process in them with Cython version.
AutobahnPython beginning with version 0.6 automatically uses WSAccell if available.
Otherwise you can run-time patch supported WebSocket libraries using:
import wsaccel
wsaccel.patch_autobahn() # for autobahn.
wsaccel.patch_ws4py() # for ws4py.
%prep
%autosetup -n wsaccel-0.6.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wsaccel -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 0.6.4-1
- Package Spec generated