%global _empty_manifest_terminate_build 0
Name: python-flake8-import-order
Version: 0.18.2
Release: 1
Summary: Flake8 and pylama plugin that checks the ordering of import statements.
License: LGPLv3
URL: https://github.com/PyCQA/flake8-import-order
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/23/55/181d5e1b70ff1c7e1ee1d5e2247dfd53f1168fe706656f57e788aa1df2ab/flake8-import-order-0.18.2.tar.gz
BuildArch: noarch
Requires: python3-pycodestyle
Requires: python3-setuptools
Requires: python3-enum34
%description
|Build Status|
A `flake8 `__ and `Pylama
`__ plugin that checks the ordering of
your imports. It does not check anything else about the
imports. Merely that they are grouped and ordered correctly.
In general stdlib comes first, then 3rd party, then local packages,
and that each group is individually alphabetized, however this depends
on the style used. Flake8-Import-Order supports a number of `styles
<#styles>`_ and is extensible allowing for `custom styles
<#extending-styles>`_.
This plugin was originally developed to match the style preferences of
the `cryptography `__ project,
with this style remaining the default.
%package -n python3-flake8-import-order
Summary: Flake8 and pylama plugin that checks the ordering of import statements.
Provides: python-flake8-import-order
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flake8-import-order
|Build Status|
A `flake8 `__ and `Pylama
`__ plugin that checks the ordering of
your imports. It does not check anything else about the
imports. Merely that they are grouped and ordered correctly.
In general stdlib comes first, then 3rd party, then local packages,
and that each group is individually alphabetized, however this depends
on the style used. Flake8-Import-Order supports a number of `styles
<#styles>`_ and is extensible allowing for `custom styles
<#extending-styles>`_.
This plugin was originally developed to match the style preferences of
the `cryptography `__ project,
with this style remaining the default.
%package help
Summary: Development documents and examples for flake8-import-order
Provides: python3-flake8-import-order-doc
%description help
|Build Status|
A `flake8 `__ and `Pylama
`__ plugin that checks the ordering of
your imports. It does not check anything else about the
imports. Merely that they are grouped and ordered correctly.
In general stdlib comes first, then 3rd party, then local packages,
and that each group is individually alphabetized, however this depends
on the style used. Flake8-Import-Order supports a number of `styles
<#styles>`_ and is extensible allowing for `custom styles
<#extending-styles>`_.
This plugin was originally developed to match the style preferences of
the `cryptography `__ project,
with this style remaining the default.
%prep
%autosetup -n flake8-import-order-0.18.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flake8-import-order -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 0.18.2-1
- Package Spec generated