%global _empty_manifest_terminate_build 0
Name: python-glances-api
Version: 0.4.1
Release: 1
Summary: Python API for interacting with Glances
License: MIT
URL: https://github.com/home-assistant-ecosystem/python-glances-api
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b1/ec/799fe89167f243018a4278ec36254e88fc64f7cc4a0efa7ecaf81bd26049/glances_api-0.4.1.tar.gz
BuildArch: noarch
Requires: python3-httpx
%description
A Python client for interacting with `Glances `_.
This module is not official, developed, supported or endorsed by Glances.
%package -n python3-glances-api
Summary: Python API for interacting with Glances
Provides: python-glances-api
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-glances-api
A Python client for interacting with `Glances `_.
This module is not official, developed, supported or endorsed by Glances.
%package help
Summary: Development documents and examples for glances-api
Provides: python3-glances-api-doc
%description help
A Python client for interacting with `Glances `_.
This module is not official, developed, supported or endorsed by Glances.
%prep
%autosetup -n glances-api-0.4.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-glances-api -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 0.4.1-1
- Package Spec generated