%global _empty_manifest_terminate_build 0
Name: python-PyMeeus
Version: 0.5.12
Release: 1
Summary: Python implementation of Jean Meeus astronomical routines
License: LGPLv3
URL: https://github.com/architest/pymeeus
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/81/76/599896b37e60f43078afd8354b3802eb7ca257a7e7f6253cc21c4c672877/PyMeeus-0.5.12.tar.gz
BuildArch: noarch
%description
**Library of astronomical algorithms in Python**.
PyMeeus is a Python implementation of the astronomical algorithms
described in the classical book 'Astronomical Algorithms, 2nd Edition,
Willmann-Bell Inc. (1998)' by Jean Meeus.
There are great astronomical libraries out there. For instance, if
you're looking for high precision and speed you should take a look at
`libnova `__. For a set of python
modules aimed at professional astronomers, you should look at
`Astropy `__. On the other hand, the advantages
of PyMeeus are its simplicity, ease of use, ease of reading, ease of
installation (it has the minimum amount of dependencies) and abundant
documentation.
%package -n python3-PyMeeus
Summary: Python implementation of Jean Meeus astronomical routines
Provides: python-PyMeeus
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PyMeeus
**Library of astronomical algorithms in Python**.
PyMeeus is a Python implementation of the astronomical algorithms
described in the classical book 'Astronomical Algorithms, 2nd Edition,
Willmann-Bell Inc. (1998)' by Jean Meeus.
There are great astronomical libraries out there. For instance, if
you're looking for high precision and speed you should take a look at
`libnova `__. For a set of python
modules aimed at professional astronomers, you should look at
`Astropy `__. On the other hand, the advantages
of PyMeeus are its simplicity, ease of use, ease of reading, ease of
installation (it has the minimum amount of dependencies) and abundant
documentation.
%package help
Summary: Development documents and examples for PyMeeus
Provides: python3-PyMeeus-doc
%description help
**Library of astronomical algorithms in Python**.
PyMeeus is a Python implementation of the astronomical algorithms
described in the classical book 'Astronomical Algorithms, 2nd Edition,
Willmann-Bell Inc. (1998)' by Jean Meeus.
There are great astronomical libraries out there. For instance, if
you're looking for high precision and speed you should take a look at
`libnova `__. For a set of python
modules aimed at professional astronomers, you should look at
`Astropy `__. On the other hand, the advantages
of PyMeeus are its simplicity, ease of use, ease of reading, ease of
installation (it has the minimum amount of dependencies) and abundant
documentation.
%prep
%autosetup -n PyMeeus-0.5.12
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PyMeeus -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 0.5.12-1
- Package Spec generated