%global _empty_manifest_terminate_build 0
Name: python-pytest-testmon
Version: 2.0.6
Release: 1
Summary: selects tests affected by changed files and methods
License: AGPL
URL: https://testmon.org
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fc/d8/1e58709080d9b0d9e51b4e638429a41d97f3ea7983e06aaadcdeb5223a3a/pytest-testmon-2.0.6.tar.gz
BuildArch: noarch
Requires: python3-pytest
Requires: python3-coverage
%description
This is a pytest plug-in which automatically selects and re-executes
only tests affected by recent changes. How is this possible in dynamic
language like Python and how reliable is it? Read here: [Determining
affected tests](https://testmon.org/blog/determining-affected-tests/)
## Quickstart
pip install pytest-testmon
# build the dependency database and save it to .testmondata
pytest --testmon
# change some of your code (with test coverage)
# only run tests affected by recent changes
pytest --testmon
To learn more about different options you can use with testmon, please
head to [testmon.org](https://testmon.org)
## Call for opensource projects: try testmon in CI with no effort or risk.
We would like to run testmon within your project, collect data and improve!
We'll prepare the PR for you and set everything up so that no tests are deselected initially.
You can start using the full functionality whenever the reliability and time savings seem right!
Please get in touch and we'll contact you shortly.
%package -n python3-pytest-testmon
Summary: selects tests affected by changed files and methods
Provides: python-pytest-testmon
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pytest-testmon
This is a pytest plug-in which automatically selects and re-executes
only tests affected by recent changes. How is this possible in dynamic
language like Python and how reliable is it? Read here: [Determining
affected tests](https://testmon.org/blog/determining-affected-tests/)
## Quickstart
pip install pytest-testmon
# build the dependency database and save it to .testmondata
pytest --testmon
# change some of your code (with test coverage)
# only run tests affected by recent changes
pytest --testmon
To learn more about different options you can use with testmon, please
head to [testmon.org](https://testmon.org)
## Call for opensource projects: try testmon in CI with no effort or risk.
We would like to run testmon within your project, collect data and improve!
We'll prepare the PR for you and set everything up so that no tests are deselected initially.
You can start using the full functionality whenever the reliability and time savings seem right!
Please get in touch and we'll contact you shortly.
%package help
Summary: Development documents and examples for pytest-testmon
Provides: python3-pytest-testmon-doc
%description help
This is a pytest plug-in which automatically selects and re-executes
only tests affected by recent changes. How is this possible in dynamic
language like Python and how reliable is it? Read here: [Determining
affected tests](https://testmon.org/blog/determining-affected-tests/)
## Quickstart
pip install pytest-testmon
# build the dependency database and save it to .testmondata
pytest --testmon
# change some of your code (with test coverage)
# only run tests affected by recent changes
pytest --testmon
To learn more about different options you can use with testmon, please
head to [testmon.org](https://testmon.org)
## Call for opensource projects: try testmon in CI with no effort or risk.
We would like to run testmon within your project, collect data and improve!
We'll prepare the PR for you and set everything up so that no tests are deselected initially.
You can start using the full functionality whenever the reliability and time savings seem right!
Please get in touch and we'll contact you shortly.
%prep
%autosetup -n pytest-testmon-2.0.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pytest-testmon -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 2.0.6-1
- Package Spec generated