%global _empty_manifest_terminate_build 0
Name: python-sphinx-gallery
Version: 0.12.2
Release: 1
Summary: A `Sphinx `_ extension that builds an HTML gallery of examples from any set of Python scripts.
License: 3-clause BSD
URL: https://sphinx-gallery.github.io
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b5/19/dbc4997a8c1ad2ce88a723aebdd923da37aaf24ad3a4a4cfe7bd5c057259/sphinx-gallery-0.12.2.tar.gz
BuildArch: noarch
Requires: python3-sphinx
%description
%package -n python3-sphinx-gallery
Summary: A `Sphinx `_ extension that builds an HTML gallery of examples from any set of Python scripts.
Provides: python-sphinx-gallery
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sphinx-gallery
%package help
Summary: Development documents and examples for sphinx-gallery
Provides: python3-sphinx-gallery-doc
%description help
%prep
%autosetup -n sphinx-gallery-0.12.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sphinx-gallery -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.12.2-1
- Package Spec generated