%global _empty_manifest_terminate_build 0
Name: python-testpath
Version: 0.6.0
Release: 1
Summary: Test utilities for code working with files and commands
License: BSD License
URL: https://pypi.org/project/testpath/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/08/ad/a3e7d580902f57e31d2181563fc4088894692bb6ef79b816344f27719cdc/testpath-0.6.0.tar.gz
BuildArch: noarch
Requires: python3-pytest
%description
Testpath is a collection of utilities for Python code working with files and commands.
It contains functions to check things on the filesystem, and tools for mocking
system commands and recording calls to those.
`Documentation on ReadTheDocs `_
e.g.::
import testpath
testpath.assert_isfile(path)
with testpath.assert_calls('git', ['add', path]):
function_under_test()
%package -n python3-testpath
Summary: Test utilities for code working with files and commands
Provides: python-testpath
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-testpath
Testpath is a collection of utilities for Python code working with files and commands.
It contains functions to check things on the filesystem, and tools for mocking
system commands and recording calls to those.
`Documentation on ReadTheDocs `_
e.g.::
import testpath
testpath.assert_isfile(path)
with testpath.assert_calls('git', ['add', path]):
function_under_test()
%package help
Summary: Development documents and examples for testpath
Provides: python3-testpath-doc
%description help
Testpath is a collection of utilities for Python code working with files and commands.
It contains functions to check things on the filesystem, and tools for mocking
system commands and recording calls to those.
`Documentation on ReadTheDocs `_
e.g.::
import testpath
testpath.assert_isfile(path)
with testpath.assert_calls('git', ['add', path]):
function_under_test()
%prep
%autosetup -n testpath-0.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-testpath -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.6.0-1
- Package Spec generated