%global _empty_manifest_terminate_build 0
Name: python-vpoller
Version: 0.7.3
Release: 1
Summary: Distributed VMware vSphere API Proxy
License: BSD
URL: https://github.com/dnaeon/py-vpoller
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fa/77/f17f025706f92f9ce87c4af4429db8cb4651f5eeed0ff048300755eb4d9c/vpoller-0.7.3.tar.gz
BuildArch: noarch
%description
vPoller is a distributed VMware vSphere API Proxy, designed for
discovering and polling of vSphere objects.
It uses the `VMware vSphere API `_
in order to perform discovery and polling of vSphere objects.
vPoller uses the `ZeroMQ messaging library `_ for
distributing tasks to workers and load balancing of client requests.
vPoller can be integrated with other systems, which require access to
vSphere objects, but do not have native support for it.
Possible scenarios where vPoller could be used is integration with
monitoring systems as part of the discovery and polling process
in order to provide monitoring of your VMware vSphere environment.
vPoller has been tested with VMware vSphere 5.x and with very limited
testing on vSphere 4.x.
vPoller is Open Source and licensed under the
`BSD License `_.
%package -n python3-vpoller
Summary: Distributed VMware vSphere API Proxy
Provides: python-vpoller
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-vpoller
vPoller is a distributed VMware vSphere API Proxy, designed for
discovering and polling of vSphere objects.
It uses the `VMware vSphere API `_
in order to perform discovery and polling of vSphere objects.
vPoller uses the `ZeroMQ messaging library `_ for
distributing tasks to workers and load balancing of client requests.
vPoller can be integrated with other systems, which require access to
vSphere objects, but do not have native support for it.
Possible scenarios where vPoller could be used is integration with
monitoring systems as part of the discovery and polling process
in order to provide monitoring of your VMware vSphere environment.
vPoller has been tested with VMware vSphere 5.x and with very limited
testing on vSphere 4.x.
vPoller is Open Source and licensed under the
`BSD License `_.
%package help
Summary: Development documents and examples for vpoller
Provides: python3-vpoller-doc
%description help
vPoller is a distributed VMware vSphere API Proxy, designed for
discovering and polling of vSphere objects.
It uses the `VMware vSphere API `_
in order to perform discovery and polling of vSphere objects.
vPoller uses the `ZeroMQ messaging library `_ for
distributing tasks to workers and load balancing of client requests.
vPoller can be integrated with other systems, which require access to
vSphere objects, but do not have native support for it.
Possible scenarios where vPoller could be used is integration with
monitoring systems as part of the discovery and polling process
in order to provide monitoring of your VMware vSphere environment.
vPoller has been tested with VMware vSphere 5.x and with very limited
testing on vSphere 4.x.
vPoller is Open Source and licensed under the
`BSD License `_.
%prep
%autosetup -n vpoller-0.7.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-vpoller -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.7.3-1
- Package Spec generated