%global _empty_manifest_terminate_build 0
Name: python-webthing
Version: 0.15.0
Release: 1
Summary: HTTP Web Thing implementation
License: MPL-2.0
URL: https://github.com/WebThingsIO/webthing-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c0/b8/8c9d29c0bc1402134e95503fdca1bb05cdac57dcb2f049831905767d65de/webthing-0.15.0.tar.gz
BuildArch: noarch
Requires: python3-ifaddr
Requires: python3-jsonschema
Requires: python3-pyee
Requires: python3-tornado
Requires: python3-zeroconf
%description
Implementation of an HTTP `Web Thing `_. This library is compatible with Python 2.7 and 3.5+.
%package -n python3-webthing
Summary: HTTP Web Thing implementation
Provides: python-webthing
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-webthing
Implementation of an HTTP `Web Thing `_. This library is compatible with Python 2.7 and 3.5+.
%package help
Summary: Development documents and examples for webthing
Provides: python3-webthing-doc
%description help
Implementation of an HTTP `Web Thing `_. This library is compatible with Python 2.7 and 3.5+.
%prep
%autosetup -n webthing-0.15.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-webthing -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.15.0-1
- Package Spec generated