%global _empty_manifest_terminate_build 0
Name: python-nox
Version: 2022.11.21
Release: 1
Summary: Flexible test automation.
License: Apache-2.0
URL: https://pypi.org/project/nox/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bb/1b/d5c87d105189bf4e3811f135c8a20c74ae9f81a34d33a1d0d1cd81383dd5/nox-2022.11.21.tar.gz
BuildArch: noarch
Requires: python3-argcomplete
Requires: python3-colorlog
Requires: python3-packaging
Requires: python3-virtualenv
Requires: python3-importlib-metadata
Requires: python3-typing-extensions
Requires: python3-jinja2
Requires: python3-tox
%description
# Nox
[![License](https://img.shields.io/github/license/wntrblm/nox)](https://github.com/wntrblm/nox)
[![PyPI](https://img.shields.io/pypi/v/nox.svg?logo=python)](https://pypi.python.org/pypi/nox)
[![GitHub](https://img.shields.io/github/v/release/wntrblm/nox?logo=github&sort=semver)](https://github.com/wntrblm/nox)
[![Code Style](https://img.shields.io/badge/code%20style-black-black)](https://github.com/wntrblm/nox)
[![CI](https://github.com/wntrblm/nox/workflows/CI/badge.svg)](https://github.com/wntrblm/nox/actions?query=workflow%3ACI)
[![Downloads](https://static.pepy.tech/personalized-badge/nox?period=total&units=international_system&left_color=grey&right_color=green&left_text=Downloads)](https://pepy.tech/project/nox)
*Flexible test automation with Python*
* **Documentation:** [https://nox.readthedocs.io](https://nox.readthedocs.io)
* **Source Code:** [https://github.com/wntrblm/nox](https://github.com/wntrblm/nox)
## Overview
`nox` is a command-line tool that automates testing in multiple Python environments, similar to [tox]. Unlike tox, Nox uses a standard Python file for configuration:
```python
import nox
@nox.session
def tests(session: nox.Session) -> None:
session.install("pytest")
session.run("pytest")
@nox.session
def lint(session: nox.Session) -> None:
session.install("flake8")
session.run("flake8", "--import-order-style", "google")
```
## Installation
Nox is designed to be installed globally (not in a project virtual environment), the recommended way of doing this is via [pipx], a tool designed to install python CLI programs whilst keeping them separate from your global or system python.
To install Nox with [pipx]:
```shell
pipx install nox
```
You can also use [pip] in your global python:
```shell
python3 -m pip install nox
```
You may want to user the [user-site] to avoid messing with your Global python install:
```shell
python3 -m pip install --user nox
```
## Usage
### List all sessions
```shell
nox -l/--list
```
### Run all sessions
```shell
nox
```
### Run a particular session
```shell
nox -s/--session test
```
Checkout the [docs](https://nox.readthedocs.io) for more! 🎉
## Contributing
Nox is an open source project and welcomes contributions of all kinds, checkout the [contributing guide](CONTRIBUTING.md) for help on how to help us out!
All contributors must follow the [code of conduct](CODE_OF_CONDUCT.md) and be nice to one another! 😃
[tox]: https://tox.readthedocs.io
[pipx]: https://pypa.github.io/pipx/
[pip]: https://pip.pypa.io/en/stable/
[user-site]: https://packaging.python.org/en/latest/tutorials/installing-packages/#installing-to-the-user-site
%package -n python3-nox
Summary: Flexible test automation.
Provides: python-nox
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-nox
# Nox
[![License](https://img.shields.io/github/license/wntrblm/nox)](https://github.com/wntrblm/nox)
[![PyPI](https://img.shields.io/pypi/v/nox.svg?logo=python)](https://pypi.python.org/pypi/nox)
[![GitHub](https://img.shields.io/github/v/release/wntrblm/nox?logo=github&sort=semver)](https://github.com/wntrblm/nox)
[![Code Style](https://img.shields.io/badge/code%20style-black-black)](https://github.com/wntrblm/nox)
[![CI](https://github.com/wntrblm/nox/workflows/CI/badge.svg)](https://github.com/wntrblm/nox/actions?query=workflow%3ACI)
[![Downloads](https://static.pepy.tech/personalized-badge/nox?period=total&units=international_system&left_color=grey&right_color=green&left_text=Downloads)](https://pepy.tech/project/nox)
*Flexible test automation with Python*
* **Documentation:** [https://nox.readthedocs.io](https://nox.readthedocs.io)
* **Source Code:** [https://github.com/wntrblm/nox](https://github.com/wntrblm/nox)
## Overview
`nox` is a command-line tool that automates testing in multiple Python environments, similar to [tox]. Unlike tox, Nox uses a standard Python file for configuration:
```python
import nox
@nox.session
def tests(session: nox.Session) -> None:
session.install("pytest")
session.run("pytest")
@nox.session
def lint(session: nox.Session) -> None:
session.install("flake8")
session.run("flake8", "--import-order-style", "google")
```
## Installation
Nox is designed to be installed globally (not in a project virtual environment), the recommended way of doing this is via [pipx], a tool designed to install python CLI programs whilst keeping them separate from your global or system python.
To install Nox with [pipx]:
```shell
pipx install nox
```
You can also use [pip] in your global python:
```shell
python3 -m pip install nox
```
You may want to user the [user-site] to avoid messing with your Global python install:
```shell
python3 -m pip install --user nox
```
## Usage
### List all sessions
```shell
nox -l/--list
```
### Run all sessions
```shell
nox
```
### Run a particular session
```shell
nox -s/--session test
```
Checkout the [docs](https://nox.readthedocs.io) for more! 🎉
## Contributing
Nox is an open source project and welcomes contributions of all kinds, checkout the [contributing guide](CONTRIBUTING.md) for help on how to help us out!
All contributors must follow the [code of conduct](CODE_OF_CONDUCT.md) and be nice to one another! 😃
[tox]: https://tox.readthedocs.io
[pipx]: https://pypa.github.io/pipx/
[pip]: https://pip.pypa.io/en/stable/
[user-site]: https://packaging.python.org/en/latest/tutorials/installing-packages/#installing-to-the-user-site
%package help
Summary: Development documents and examples for nox
Provides: python3-nox-doc
%description help
# Nox
[![License](https://img.shields.io/github/license/wntrblm/nox)](https://github.com/wntrblm/nox)
[![PyPI](https://img.shields.io/pypi/v/nox.svg?logo=python)](https://pypi.python.org/pypi/nox)
[![GitHub](https://img.shields.io/github/v/release/wntrblm/nox?logo=github&sort=semver)](https://github.com/wntrblm/nox)
[![Code Style](https://img.shields.io/badge/code%20style-black-black)](https://github.com/wntrblm/nox)
[![CI](https://github.com/wntrblm/nox/workflows/CI/badge.svg)](https://github.com/wntrblm/nox/actions?query=workflow%3ACI)
[![Downloads](https://static.pepy.tech/personalized-badge/nox?period=total&units=international_system&left_color=grey&right_color=green&left_text=Downloads)](https://pepy.tech/project/nox)
*Flexible test automation with Python*
* **Documentation:** [https://nox.readthedocs.io](https://nox.readthedocs.io)
* **Source Code:** [https://github.com/wntrblm/nox](https://github.com/wntrblm/nox)
## Overview
`nox` is a command-line tool that automates testing in multiple Python environments, similar to [tox]. Unlike tox, Nox uses a standard Python file for configuration:
```python
import nox
@nox.session
def tests(session: nox.Session) -> None:
session.install("pytest")
session.run("pytest")
@nox.session
def lint(session: nox.Session) -> None:
session.install("flake8")
session.run("flake8", "--import-order-style", "google")
```
## Installation
Nox is designed to be installed globally (not in a project virtual environment), the recommended way of doing this is via [pipx], a tool designed to install python CLI programs whilst keeping them separate from your global or system python.
To install Nox with [pipx]:
```shell
pipx install nox
```
You can also use [pip] in your global python:
```shell
python3 -m pip install nox
```
You may want to user the [user-site] to avoid messing with your Global python install:
```shell
python3 -m pip install --user nox
```
## Usage
### List all sessions
```shell
nox -l/--list
```
### Run all sessions
```shell
nox
```
### Run a particular session
```shell
nox -s/--session test
```
Checkout the [docs](https://nox.readthedocs.io) for more! 🎉
## Contributing
Nox is an open source project and welcomes contributions of all kinds, checkout the [contributing guide](CONTRIBUTING.md) for help on how to help us out!
All contributors must follow the [code of conduct](CODE_OF_CONDUCT.md) and be nice to one another! 😃
[tox]: https://tox.readthedocs.io
[pipx]: https://pypa.github.io/pipx/
[pip]: https://pip.pypa.io/en/stable/
[user-site]: https://packaging.python.org/en/latest/tutorials/installing-packages/#installing-to-the-user-site
%prep
%autosetup -n nox-2022.11.21
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-nox -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 2022.11.21-1
- Package Spec generated