%global _empty_manifest_terminate_build 0
Name: python-bugsnag
Version: 4.4.0
Release: 1
Summary: Automatic error monitoring for django, flask, etc.
License: MIT
URL: https://bugsnag.com/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/31/36/4d5eb676072ea647f0172cfac11d4c747c6bf660334e32f31c6b4aebfd71/bugsnag-4.4.0.tar.gz
BuildArch: noarch
Requires: python3-webob
Requires: python3-flask
Requires: python3-blinker
%description
The official Python notifier for `Bugsnag `_.
Provides support for automatically capturing and sending exceptions
in your Django and other Python apps to Bugsnag, to help you find
and solve your bugs as fast as possible.
%package -n python3-bugsnag
Summary: Automatic error monitoring for django, flask, etc.
Provides: python-bugsnag
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bugsnag
The official Python notifier for `Bugsnag `_.
Provides support for automatically capturing and sending exceptions
in your Django and other Python apps to Bugsnag, to help you find
and solve your bugs as fast as possible.
%package help
Summary: Development documents and examples for bugsnag
Provides: python3-bugsnag-doc
%description help
The official Python notifier for `Bugsnag `_.
Provides support for automatically capturing and sending exceptions
in your Django and other Python apps to Bugsnag, to help you find
and solve your bugs as fast as possible.
%prep
%autosetup -n bugsnag-4.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bugsnag -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 4.4.0-1
- Package Spec generated