%global _empty_manifest_terminate_build 0
Name: python-django-anymail
Version: 9.1
Release: 1
Summary: Django email backends and webhooks for Amazon SES, MailerSend, Mailgun, Mailjet, Mandrill, Postal, Postmark, SendGrid, SendinBlue, and SparkPost
License: BSD License
URL: https://github.com/anymail/django-anymail
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c7/94/fce13f267050a627d5274cc9adc930f5c78413a637e07af60ac48ee30dc4/django-anymail-9.1.tar.gz
BuildArch: noarch
Requires: python3-django
Requires: python3-requests
Requires: python3-boto3
Requires: python3-pre-commit
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-tox
Requires: python3-twine
Requires: python3-wheel
Requires: python3-cryptography
%description
* Github: project page, exactly as it appears here
* Docs: shared-intro section gets included in docs/index.rst
quickstart section gets included in docs/quickstart.rst
* PyPI: project page (via setup.py long_description),
with several edits to freeze it to the specific PyPI release
(see long_description_from_readme in setup.py)
You can use docutils 1.0 markup, but *not* any Sphinx additions.
GitHub rst supports code-block, but *no other* block directives.
Anymail lets you send and receive email in Django using your choice
of transactional email service providers (ESPs). It extends the
standard `django.core.mail` with many common ESP-added features, providing
a consistent API that avoids locking your code to one specific ESP
(and making it easier to change ESPs later if needed).
Anymail currently supports these ESPs:
* **Amazon SES**
* **MailerSend**
* **Mailgun**
* **Mailjet**
* **Mandrill** (MailChimp transactional)
* **Postal** (self-hosted ESP)
* **Postmark**
* **SendGrid**
* **SendinBlue**
* **SparkPost**
Anymail includes:
* Integration of each ESP's sending APIs into
`Django's built-in email `_
package, including support for HTML, attachments, extra headers,
and other standard email features
* Extensions to expose common ESP-added functionality, like tags, metadata,
and tracking, with code that's portable between ESPs
* Simplified inline images for HTML email
* Normalized sent-message status and tracking notification, by connecting
your ESP's webhooks to Django signals
* "Batch transactional" sends using your ESP's merge and template features
* Inbound message support, to receive email through your ESP's webhooks,
with simplified, portable access to attachments and other inbound content
Anymail maintains compatibility with all Django versions that are in mainstream
or extended support, plus (usually) a few older Django versions, and is extensively
tested on all Python versions supported by Django. (Even-older Django versions
may still be covered by an Anymail extended support release; consult the
`changelog `_ for details.)
Anymail releases follow `semantic versioning `_.
The package is released under the BSD license.
**Resources**
* Full documentation: https://anymail.dev/en/v9.1/
* Help and troubleshooting: https://anymail.dev/en/v9.1/help/
* Package on PyPI: https://pypi.org/project/django-anymail/
* Project on Github: https://github.com/anymail/django-anymail
* Changelog: https://anymail.dev/en/v9.1/changelog/
%package -n python3-django-anymail
Summary: Django email backends and webhooks for Amazon SES, MailerSend, Mailgun, Mailjet, Mandrill, Postal, Postmark, SendGrid, SendinBlue, and SparkPost
Provides: python-django-anymail
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-anymail
* Github: project page, exactly as it appears here
* Docs: shared-intro section gets included in docs/index.rst
quickstart section gets included in docs/quickstart.rst
* PyPI: project page (via setup.py long_description),
with several edits to freeze it to the specific PyPI release
(see long_description_from_readme in setup.py)
You can use docutils 1.0 markup, but *not* any Sphinx additions.
GitHub rst supports code-block, but *no other* block directives.
Anymail lets you send and receive email in Django using your choice
of transactional email service providers (ESPs). It extends the
standard `django.core.mail` with many common ESP-added features, providing
a consistent API that avoids locking your code to one specific ESP
(and making it easier to change ESPs later if needed).
Anymail currently supports these ESPs:
* **Amazon SES**
* **MailerSend**
* **Mailgun**
* **Mailjet**
* **Mandrill** (MailChimp transactional)
* **Postal** (self-hosted ESP)
* **Postmark**
* **SendGrid**
* **SendinBlue**
* **SparkPost**
Anymail includes:
* Integration of each ESP's sending APIs into
`Django's built-in email `_
package, including support for HTML, attachments, extra headers,
and other standard email features
* Extensions to expose common ESP-added functionality, like tags, metadata,
and tracking, with code that's portable between ESPs
* Simplified inline images for HTML email
* Normalized sent-message status and tracking notification, by connecting
your ESP's webhooks to Django signals
* "Batch transactional" sends using your ESP's merge and template features
* Inbound message support, to receive email through your ESP's webhooks,
with simplified, portable access to attachments and other inbound content
Anymail maintains compatibility with all Django versions that are in mainstream
or extended support, plus (usually) a few older Django versions, and is extensively
tested on all Python versions supported by Django. (Even-older Django versions
may still be covered by an Anymail extended support release; consult the
`changelog `_ for details.)
Anymail releases follow `semantic versioning `_.
The package is released under the BSD license.
**Resources**
* Full documentation: https://anymail.dev/en/v9.1/
* Help and troubleshooting: https://anymail.dev/en/v9.1/help/
* Package on PyPI: https://pypi.org/project/django-anymail/
* Project on Github: https://github.com/anymail/django-anymail
* Changelog: https://anymail.dev/en/v9.1/changelog/
%package help
Summary: Development documents and examples for django-anymail
Provides: python3-django-anymail-doc
%description help
* Github: project page, exactly as it appears here
* Docs: shared-intro section gets included in docs/index.rst
quickstart section gets included in docs/quickstart.rst
* PyPI: project page (via setup.py long_description),
with several edits to freeze it to the specific PyPI release
(see long_description_from_readme in setup.py)
You can use docutils 1.0 markup, but *not* any Sphinx additions.
GitHub rst supports code-block, but *no other* block directives.
Anymail lets you send and receive email in Django using your choice
of transactional email service providers (ESPs). It extends the
standard `django.core.mail` with many common ESP-added features, providing
a consistent API that avoids locking your code to one specific ESP
(and making it easier to change ESPs later if needed).
Anymail currently supports these ESPs:
* **Amazon SES**
* **MailerSend**
* **Mailgun**
* **Mailjet**
* **Mandrill** (MailChimp transactional)
* **Postal** (self-hosted ESP)
* **Postmark**
* **SendGrid**
* **SendinBlue**
* **SparkPost**
Anymail includes:
* Integration of each ESP's sending APIs into
`Django's built-in email `_
package, including support for HTML, attachments, extra headers,
and other standard email features
* Extensions to expose common ESP-added functionality, like tags, metadata,
and tracking, with code that's portable between ESPs
* Simplified inline images for HTML email
* Normalized sent-message status and tracking notification, by connecting
your ESP's webhooks to Django signals
* "Batch transactional" sends using your ESP's merge and template features
* Inbound message support, to receive email through your ESP's webhooks,
with simplified, portable access to attachments and other inbound content
Anymail maintains compatibility with all Django versions that are in mainstream
or extended support, plus (usually) a few older Django versions, and is extensively
tested on all Python versions supported by Django. (Even-older Django versions
may still be covered by an Anymail extended support release; consult the
`changelog `_ for details.)
Anymail releases follow `semantic versioning `_.
The package is released under the BSD license.
**Resources**
* Full documentation: https://anymail.dev/en/v9.1/
* Help and troubleshooting: https://anymail.dev/en/v9.1/help/
* Package on PyPI: https://pypi.org/project/django-anymail/
* Project on Github: https://github.com/anymail/django-anymail
* Changelog: https://anymail.dev/en/v9.1/changelog/
%prep
%autosetup -n django-anymail-9.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-anymail -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 9.1-1
- Package Spec generated