%global _empty_manifest_terminate_build 0
Name: python-cupy
Version: 12.0.0
Release: 1
Summary: CuPy: NumPy & SciPy for GPU
License: MIT License
URL: https://cupy.dev/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7d/9a/5c9e4947efc4c7e20287b40ec69456e1ed719f08657f88467401bb61abd7/cupy-12.0.0.tar.gz
BuildArch: noarch
%description
`CuPy `_ is a NumPy/SciPy-compatible array library for GPU-accelerated computing with Python.
This package (``cupy``) is a source distribution.
For most users, use of pre-build wheel distributions are recommended:
- `cupy-cuda12x `_ (for CUDA 12.x)
- `cupy-cuda11x `_ (for CUDA 11.2 ~ 11.x)
- `cupy-cuda111 `_ (for CUDA 11.1)
- `cupy-cuda110 `_ (for CUDA 11.0)
- `cupy-cuda102 `_ (for CUDA 10.2)
- `cupy-rocm-5-0 `_ (for ROCm 5.0)
- `cupy-rocm-4-3 `_ (for ROCm 4.3)
Please see `Installation Guide `_ for the detailed instructions.
%package -n python3-cupy
Summary: CuPy: NumPy & SciPy for GPU
Provides: python-cupy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cupy
`CuPy `_ is a NumPy/SciPy-compatible array library for GPU-accelerated computing with Python.
This package (``cupy``) is a source distribution.
For most users, use of pre-build wheel distributions are recommended:
- `cupy-cuda12x `_ (for CUDA 12.x)
- `cupy-cuda11x `_ (for CUDA 11.2 ~ 11.x)
- `cupy-cuda111 `_ (for CUDA 11.1)
- `cupy-cuda110 `_ (for CUDA 11.0)
- `cupy-cuda102 `_ (for CUDA 10.2)
- `cupy-rocm-5-0 `_ (for ROCm 5.0)
- `cupy-rocm-4-3 `_ (for ROCm 4.3)
Please see `Installation Guide `_ for the detailed instructions.
%package help
Summary: Development documents and examples for cupy
Provides: python3-cupy-doc
%description help
`CuPy `_ is a NumPy/SciPy-compatible array library for GPU-accelerated computing with Python.
This package (``cupy``) is a source distribution.
For most users, use of pre-build wheel distributions are recommended:
- `cupy-cuda12x `_ (for CUDA 12.x)
- `cupy-cuda11x `_ (for CUDA 11.2 ~ 11.x)
- `cupy-cuda111 `_ (for CUDA 11.1)
- `cupy-cuda110 `_ (for CUDA 11.0)
- `cupy-cuda102 `_ (for CUDA 10.2)
- `cupy-rocm-5-0 `_ (for ROCm 5.0)
- `cupy-rocm-4-3 `_ (for ROCm 4.3)
Please see `Installation Guide `_ for the detailed instructions.
%prep
%autosetup -n cupy-12.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cupy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 12.0.0-1
- Package Spec generated