%global _empty_manifest_terminate_build 0
Name: python-pyjq
Version: 2.6.0
Release: 1
Summary: Binding for jq JSON processor.
License: MIT License
URL: http://github.com/doloopwhile/pyjq
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8e/a7/678a3f5d458c9c1002adf4938a5df830448254423095ce68d2171abf5b21/pyjq-2.6.0.tar.gz
BuildArch: noarch
%description
[![CircleCI](https://circleci.com/gh/doloopwhile/pyjq.svg?style=svg)](https://circleci.com/gh/doloopwhile/pyjq)
pyjq is a Python bindings for jq ().
> jq is like sed for JSON data - you can use it to slice and filter and
> map and transform structured data with the same ease that sed, awk,
> grep and friends let you play with text.
>
>
You can seamlessly call jq script (like regular expression) and process
a plain python data structure.
For your information, is another jq
binding which is different and incompatible with pyjq.
%package -n python3-pyjq
Summary: Binding for jq JSON processor.
Provides: python-pyjq
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyjq
[![CircleCI](https://circleci.com/gh/doloopwhile/pyjq.svg?style=svg)](https://circleci.com/gh/doloopwhile/pyjq)
pyjq is a Python bindings for jq ().
> jq is like sed for JSON data - you can use it to slice and filter and
> map and transform structured data with the same ease that sed, awk,
> grep and friends let you play with text.
>
>
You can seamlessly call jq script (like regular expression) and process
a plain python data structure.
For your information, is another jq
binding which is different and incompatible with pyjq.
%package help
Summary: Development documents and examples for pyjq
Provides: python3-pyjq-doc
%description help
[![CircleCI](https://circleci.com/gh/doloopwhile/pyjq.svg?style=svg)](https://circleci.com/gh/doloopwhile/pyjq)
pyjq is a Python bindings for jq ().
> jq is like sed for JSON data - you can use it to slice and filter and
> map and transform structured data with the same ease that sed, awk,
> grep and friends let you play with text.
>
>
You can seamlessly call jq script (like regular expression) and process
a plain python data structure.
For your information, is another jq
binding which is different and incompatible with pyjq.
%prep
%autosetup -n pyjq-2.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyjq -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 2.6.0-1
- Package Spec generated