%global _empty_manifest_terminate_build 0
Name: python-webdrivermanager
Version: 0.10.0
Release: 1
Summary: Module for facilitating download and deploy of WebDriver binaries.
License: MIT
URL: https://github.com/rasjani/webdrivermanager
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3c/75/81b306150423486803c6fd8a28d83fc91b992a089c7059e63c231cdefef1/webdrivermanager-0.10.0.tar.gz
BuildArch: noarch
%description
Python module to facilitate downloading and deploying `WebDriver `_ binaries. The classes in this module can be used to automatically search for and download the latest version (or a specific version) of a WebDriver binary and then extract it and place it by copying or symlinking it to the location where Selenium or other tools should be able to find it then.
%package -n python3-webdrivermanager
Summary: Module for facilitating download and deploy of WebDriver binaries.
Provides: python-webdrivermanager
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-webdrivermanager
Python module to facilitate downloading and deploying `WebDriver `_ binaries. The classes in this module can be used to automatically search for and download the latest version (or a specific version) of a WebDriver binary and then extract it and place it by copying or symlinking it to the location where Selenium or other tools should be able to find it then.
%package help
Summary: Development documents and examples for webdrivermanager
Provides: python3-webdrivermanager-doc
%description help
Python module to facilitate downloading and deploying `WebDriver `_ binaries. The classes in this module can be used to automatically search for and download the latest version (or a specific version) of a WebDriver binary and then extract it and place it by copying or symlinking it to the location where Selenium or other tools should be able to find it then.
%prep
%autosetup -n webdrivermanager-0.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-webdrivermanager -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.10.0-1
- Package Spec generated