%global _empty_manifest_terminate_build 0
Name: python-django-crum
Version: 0.7.9
Release: 1
Summary: Django middleware to capture current request and user.
License: BSD
URL: https://github.com/ninemoreminutes/django-crum/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/34/1d/c56588f67130aeef8828e47535e8551337d2ae02f91f1414da61bc5e49fb/django-crum-0.7.9.tar.gz
BuildArch: noarch
Requires: python3-django
%description
Django-CRUM (Current Request User Middleware) captures the current request and
user in thread local storage.
It enables apps to check permissions, capture audit trails or otherwise access
the current request and user without requiring the request object to be passed
directly. It also offers a context manager to allow for temporarily
impersonating another user.
It provides a signal to extend the built-in function for getting the current
user, which could be helpful when using custom authentication methods or user
models.
Documentation can be found at `RTFD `_.
It is tested against:
* Django 1.11 (Python 3.5 and 3.6)
* Django 2.0 (Python 3.5, 3.6 and 3.7)
* Django 2.1 (Python 3.5, 3.6 and 3.7)
* Django 2.2 (Python 3.5, 3.6, 3.7, 3.8 and 3.9)
* Django 3.0 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.1 (Python 3.6, 3.7, 3.8 and 3.9)
* Django master/3.2 (Python 3.6, 3.7, 3.8 and 3.9)
%package -n python3-django-crum
Summary: Django middleware to capture current request and user.
Provides: python-django-crum
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-crum
Django-CRUM (Current Request User Middleware) captures the current request and
user in thread local storage.
It enables apps to check permissions, capture audit trails or otherwise access
the current request and user without requiring the request object to be passed
directly. It also offers a context manager to allow for temporarily
impersonating another user.
It provides a signal to extend the built-in function for getting the current
user, which could be helpful when using custom authentication methods or user
models.
Documentation can be found at `RTFD `_.
It is tested against:
* Django 1.11 (Python 3.5 and 3.6)
* Django 2.0 (Python 3.5, 3.6 and 3.7)
* Django 2.1 (Python 3.5, 3.6 and 3.7)
* Django 2.2 (Python 3.5, 3.6, 3.7, 3.8 and 3.9)
* Django 3.0 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.1 (Python 3.6, 3.7, 3.8 and 3.9)
* Django master/3.2 (Python 3.6, 3.7, 3.8 and 3.9)
%package help
Summary: Development documents and examples for django-crum
Provides: python3-django-crum-doc
%description help
Django-CRUM (Current Request User Middleware) captures the current request and
user in thread local storage.
It enables apps to check permissions, capture audit trails or otherwise access
the current request and user without requiring the request object to be passed
directly. It also offers a context manager to allow for temporarily
impersonating another user.
It provides a signal to extend the built-in function for getting the current
user, which could be helpful when using custom authentication methods or user
models.
Documentation can be found at `RTFD `_.
It is tested against:
* Django 1.11 (Python 3.5 and 3.6)
* Django 2.0 (Python 3.5, 3.6 and 3.7)
* Django 2.1 (Python 3.5, 3.6 and 3.7)
* Django 2.2 (Python 3.5, 3.6, 3.7, 3.8 and 3.9)
* Django 3.0 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.1 (Python 3.6, 3.7, 3.8 and 3.9)
* Django master/3.2 (Python 3.6, 3.7, 3.8 and 3.9)
%prep
%autosetup -n django-crum-0.7.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-crum -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.7.9-1
- Package Spec generated