%global _empty_manifest_terminate_build 0
Name: python-pygdal
Version: 3.5.1.11
Release: 1
Summary: Virtualenv and setuptools friendly version of standard GDAL python bindings
License: MIT
URL: https://github.com/nextgis/pygdal
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/79/61/af7bf6b11ee864c2e44996eab315deebe2f42c09deee2694ab4ab9bfee7e/pygdal-3.5.1.11.tar.gz
BuildArch: noarch
%description
b'pygdal\n======\n\nVirtualenv and setuptools friendly version of standard GDAL python bindings.\n\nThis package is for you if you had problems installing GDAL in your virtualenv. You can install GDAL into your virtualenv using this package but you still need to install GDAL library and its header files on your system. On Ubuntu it can be done this way:\n\n::\n\n $ sudo apt-get install libgdal1-dev\n\nVersion of the same package, and GDAL, so that if you have installed GDAL 1.8.1 you need to install the version 1.8.1 of this package:\n\n::\n\n $ gdal-config --version\n 1.8.1\n\n $ git clone git@github.com:nextgis/pygdal.git\n $ cd pygdal\n $ virtualenv --no-site-packages env\n $ env/bin/pip install 1.8.1/\n\nOr you can install package directly from PyPi:\n\n::\n\n $ virtualenv --no-site-packages env\n $ env/bin/pip install pygdal=="`gdal-config --version`.*"\n\nThe trick with range of versions required to support pygdal versioning.\n\nThe supported versions are ``1.8.1`` - ``3.4.2``. Package ``numpy`` is also listed as a dependency (using ``setup_requires`` and ``install_requires`` directives), so you do not need to install it before installing GDAL.\n\nIf you installed GDAL using the `KyngChaos frameworks `_, you may need to override the default values returned by ``gdal-config --prefix`` in order to install this package. This can be accomplished by setting the ``GDALHOME`` environment variable, e.g.\n\n::\n\n $ export GDALHOME="/Library/Frameworks/GDAL.framework/Versions/Current/unix/"\n $ env/bin/pip install pygdal=="`gdal-config --version`.*"\n\nAfter package is installed you can use is same way as standard GDAL bindings:\n\n::\n\n from osgeo import gdal\n\n'
%package -n python3-pygdal
Summary: Virtualenv and setuptools friendly version of standard GDAL python bindings
Provides: python-pygdal
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pygdal
b'pygdal\n======\n\nVirtualenv and setuptools friendly version of standard GDAL python bindings.\n\nThis package is for you if you had problems installing GDAL in your virtualenv. You can install GDAL into your virtualenv using this package but you still need to install GDAL library and its header files on your system. On Ubuntu it can be done this way:\n\n::\n\n $ sudo apt-get install libgdal1-dev\n\nVersion of the same package, and GDAL, so that if you have installed GDAL 1.8.1 you need to install the version 1.8.1 of this package:\n\n::\n\n $ gdal-config --version\n 1.8.1\n\n $ git clone git@github.com:nextgis/pygdal.git\n $ cd pygdal\n $ virtualenv --no-site-packages env\n $ env/bin/pip install 1.8.1/\n\nOr you can install package directly from PyPi:\n\n::\n\n $ virtualenv --no-site-packages env\n $ env/bin/pip install pygdal=="`gdal-config --version`.*"\n\nThe trick with range of versions required to support pygdal versioning.\n\nThe supported versions are ``1.8.1`` - ``3.4.2``. Package ``numpy`` is also listed as a dependency (using ``setup_requires`` and ``install_requires`` directives), so you do not need to install it before installing GDAL.\n\nIf you installed GDAL using the `KyngChaos frameworks `_, you may need to override the default values returned by ``gdal-config --prefix`` in order to install this package. This can be accomplished by setting the ``GDALHOME`` environment variable, e.g.\n\n::\n\n $ export GDALHOME="/Library/Frameworks/GDAL.framework/Versions/Current/unix/"\n $ env/bin/pip install pygdal=="`gdal-config --version`.*"\n\nAfter package is installed you can use is same way as standard GDAL bindings:\n\n::\n\n from osgeo import gdal\n\n'
%package help
Summary: Development documents and examples for pygdal
Provides: python3-pygdal-doc
%description help
b'pygdal\n======\n\nVirtualenv and setuptools friendly version of standard GDAL python bindings.\n\nThis package is for you if you had problems installing GDAL in your virtualenv. You can install GDAL into your virtualenv using this package but you still need to install GDAL library and its header files on your system. On Ubuntu it can be done this way:\n\n::\n\n $ sudo apt-get install libgdal1-dev\n\nVersion of the same package, and GDAL, so that if you have installed GDAL 1.8.1 you need to install the version 1.8.1 of this package:\n\n::\n\n $ gdal-config --version\n 1.8.1\n\n $ git clone git@github.com:nextgis/pygdal.git\n $ cd pygdal\n $ virtualenv --no-site-packages env\n $ env/bin/pip install 1.8.1/\n\nOr you can install package directly from PyPi:\n\n::\n\n $ virtualenv --no-site-packages env\n $ env/bin/pip install pygdal=="`gdal-config --version`.*"\n\nThe trick with range of versions required to support pygdal versioning.\n\nThe supported versions are ``1.8.1`` - ``3.4.2``. Package ``numpy`` is also listed as a dependency (using ``setup_requires`` and ``install_requires`` directives), so you do not need to install it before installing GDAL.\n\nIf you installed GDAL using the `KyngChaos frameworks `_, you may need to override the default values returned by ``gdal-config --prefix`` in order to install this package. This can be accomplished by setting the ``GDALHOME`` environment variable, e.g.\n\n::\n\n $ export GDALHOME="/Library/Frameworks/GDAL.framework/Versions/Current/unix/"\n $ env/bin/pip install pygdal=="`gdal-config --version`.*"\n\nAfter package is installed you can use is same way as standard GDAL bindings:\n\n::\n\n from osgeo import gdal\n\n'
%prep
%autosetup -n pygdal-3.5.1.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pygdal -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 3.5.1.11-1
- Package Spec generated