%global _empty_manifest_terminate_build 0
Name: python-django-cms
Version: 3.11.1
Release: 1
Summary: Lean enterprise content management powered by Django.
License: BSD-3-Clause
URL: https://www.django-cms.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9d/0d/5e45448ab31256be7b1ecb24064ead0ff13a62e1d997e53f085a7d87725a/django-cms-3.11.1.tar.gz
BuildArch: noarch
Requires: python3-Django
Requires: python3-django-classy-tags
Requires: python3-django-formtools
Requires: python3-django-treebeard
Requires: python3-django-sekizai
Requires: python3-djangocms-admin-style
%description
##########
django CMS
##########
.. image:: https://travis-ci.org/django-cms/django-cms.svg?branch=develop
:target: https://travis-ci.org/django-cms/django-cms
.. image:: https://img.shields.io/pypi/v/django-cms.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://img.shields.io/badge/wheel-yes-green.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://img.shields.io/pypi/l/django-cms.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://codeclimate.com/github/divio/django-cms/badges/gpa.svg
:target: https://codeclimate.com/github/divio/django-cms
:alt: Code Climate
Open source enterprise content management system based on the Django framework and backed by the non-profit django CMS Association (`Sponsor us! `_).
*******************************************
Contribute to this project and win rewards
*******************************************
Because django CMS is a community-driven project, we welcome everyone to `get involved in the project `_ and `receive a reward `_ for their contribution. Become part of a fantastic community and help us make django CMS the best open source CMS in the world.
.. ATTENTION::
Please use the ``develop`` branch as the target for pull requests for on-going development.
Security fixes will be backported to older branches by the core team as appropriate.
********
Features
********
* hierarchical pages
* extensive built-in support for multilingual websites
* multi-site support
* draft/publish workflows
* version control
* a sophisticated publishing architecture, that's also usable in your own applications
* frontend content editing
* a hierarchical content structure for nested plugins
* an extensible navigation system that your own applications can hook into
* SEO-friendly URLs
* designed to integrate thoroughly into other applications
Developing applications that integrate with and take advantage of django CMS features is easy and well-documented.
More information on `our website `_.
************
Requirements
************
See the `Python/Django requirements for the current release version
`_ in our documentation.
See the `installation how-to guide for an overview of some other requirements and dependencies of the current release
`_.
***************
Getting started
***************
These `tutorials `_ take you step-by-step through some key aspects of django CMS.
*************
Documentation
*************
Our documentation working group maintains documentation for several versions of the project. Key versions are:
* `stable `_ (default), for the **current release** version
* `latest `_, representing the latest build of the **release-3.4.x branch**
* `develop `_, representing the latest build of the **develop branch**
For more information about our branch policy, see `Branches
`_.
Our documentation is hosted courtesy of `Read the Docs `_.
The dependencies for the docs are compiled by `pip-tools `_.
***************************
Test django CMS in our demo
***************************
The demo platform is kindly provided by Divio, platinum member of the django CMS Association.
.. image:: https://raw.githubusercontent.com/django-cms/django-cms/develop/docs/images/try-with-divio.png
:target: https://www.django-cms.org/en/django-cms-demo/
:alt: Try demo with Divio Cloud
************
Getting Help
************
Please head over to our `Slack channel `_ or our `discourse forum `_ for support.
********************
Professional support
********************
Choose from a list of `trusted tech partner `_ of the django CMS Association to get your website project delivered successfully.
Choose a `trusted web host `_ for your django CMS project and get your website online today.
**************************
The django CMS Association
**************************
The django CMS Association is a non-profit organization that was founded in 2020 with the goal to drive the success of django CMS, by increasing customer happiness, market share and open-source contributions. We provide infrastructure and guidance for the django CMS project.
The non-profit django CMS Association is dependent on donations to fulfill its purpose. The best way to donate is to become a member of the association and pay membership fees. The funding will be funneled back into core development and community projects.
`Join the django CMS Association `_.
*******
Credits
*******
* Includes icons from `FamFamFam `_.
* Python tree engine powered by
`django-treebeard `_.
* JavaScript tree in admin uses `jsTree `_.
* Many thanks to
`all the contributors `_
to django CMS!
%package -n python3-django-cms
Summary: Lean enterprise content management powered by Django.
Provides: python-django-cms
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-cms
##########
django CMS
##########
.. image:: https://travis-ci.org/django-cms/django-cms.svg?branch=develop
:target: https://travis-ci.org/django-cms/django-cms
.. image:: https://img.shields.io/pypi/v/django-cms.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://img.shields.io/badge/wheel-yes-green.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://img.shields.io/pypi/l/django-cms.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://codeclimate.com/github/divio/django-cms/badges/gpa.svg
:target: https://codeclimate.com/github/divio/django-cms
:alt: Code Climate
Open source enterprise content management system based on the Django framework and backed by the non-profit django CMS Association (`Sponsor us! `_).
*******************************************
Contribute to this project and win rewards
*******************************************
Because django CMS is a community-driven project, we welcome everyone to `get involved in the project `_ and `receive a reward `_ for their contribution. Become part of a fantastic community and help us make django CMS the best open source CMS in the world.
.. ATTENTION::
Please use the ``develop`` branch as the target for pull requests for on-going development.
Security fixes will be backported to older branches by the core team as appropriate.
********
Features
********
* hierarchical pages
* extensive built-in support for multilingual websites
* multi-site support
* draft/publish workflows
* version control
* a sophisticated publishing architecture, that's also usable in your own applications
* frontend content editing
* a hierarchical content structure for nested plugins
* an extensible navigation system that your own applications can hook into
* SEO-friendly URLs
* designed to integrate thoroughly into other applications
Developing applications that integrate with and take advantage of django CMS features is easy and well-documented.
More information on `our website `_.
************
Requirements
************
See the `Python/Django requirements for the current release version
`_ in our documentation.
See the `installation how-to guide for an overview of some other requirements and dependencies of the current release
`_.
***************
Getting started
***************
These `tutorials `_ take you step-by-step through some key aspects of django CMS.
*************
Documentation
*************
Our documentation working group maintains documentation for several versions of the project. Key versions are:
* `stable `_ (default), for the **current release** version
* `latest `_, representing the latest build of the **release-3.4.x branch**
* `develop `_, representing the latest build of the **develop branch**
For more information about our branch policy, see `Branches
`_.
Our documentation is hosted courtesy of `Read the Docs `_.
The dependencies for the docs are compiled by `pip-tools `_.
***************************
Test django CMS in our demo
***************************
The demo platform is kindly provided by Divio, platinum member of the django CMS Association.
.. image:: https://raw.githubusercontent.com/django-cms/django-cms/develop/docs/images/try-with-divio.png
:target: https://www.django-cms.org/en/django-cms-demo/
:alt: Try demo with Divio Cloud
************
Getting Help
************
Please head over to our `Slack channel `_ or our `discourse forum `_ for support.
********************
Professional support
********************
Choose from a list of `trusted tech partner `_ of the django CMS Association to get your website project delivered successfully.
Choose a `trusted web host `_ for your django CMS project and get your website online today.
**************************
The django CMS Association
**************************
The django CMS Association is a non-profit organization that was founded in 2020 with the goal to drive the success of django CMS, by increasing customer happiness, market share and open-source contributions. We provide infrastructure and guidance for the django CMS project.
The non-profit django CMS Association is dependent on donations to fulfill its purpose. The best way to donate is to become a member of the association and pay membership fees. The funding will be funneled back into core development and community projects.
`Join the django CMS Association `_.
*******
Credits
*******
* Includes icons from `FamFamFam `_.
* Python tree engine powered by
`django-treebeard `_.
* JavaScript tree in admin uses `jsTree `_.
* Many thanks to
`all the contributors `_
to django CMS!
%package help
Summary: Development documents and examples for django-cms
Provides: python3-django-cms-doc
%description help
##########
django CMS
##########
.. image:: https://travis-ci.org/django-cms/django-cms.svg?branch=develop
:target: https://travis-ci.org/django-cms/django-cms
.. image:: https://img.shields.io/pypi/v/django-cms.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://img.shields.io/badge/wheel-yes-green.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://img.shields.io/pypi/l/django-cms.svg
:target: https://pypi.python.org/pypi/django-cms/
.. image:: https://codeclimate.com/github/divio/django-cms/badges/gpa.svg
:target: https://codeclimate.com/github/divio/django-cms
:alt: Code Climate
Open source enterprise content management system based on the Django framework and backed by the non-profit django CMS Association (`Sponsor us! `_).
*******************************************
Contribute to this project and win rewards
*******************************************
Because django CMS is a community-driven project, we welcome everyone to `get involved in the project `_ and `receive a reward `_ for their contribution. Become part of a fantastic community and help us make django CMS the best open source CMS in the world.
.. ATTENTION::
Please use the ``develop`` branch as the target for pull requests for on-going development.
Security fixes will be backported to older branches by the core team as appropriate.
********
Features
********
* hierarchical pages
* extensive built-in support for multilingual websites
* multi-site support
* draft/publish workflows
* version control
* a sophisticated publishing architecture, that's also usable in your own applications
* frontend content editing
* a hierarchical content structure for nested plugins
* an extensible navigation system that your own applications can hook into
* SEO-friendly URLs
* designed to integrate thoroughly into other applications
Developing applications that integrate with and take advantage of django CMS features is easy and well-documented.
More information on `our website `_.
************
Requirements
************
See the `Python/Django requirements for the current release version
`_ in our documentation.
See the `installation how-to guide for an overview of some other requirements and dependencies of the current release
`_.
***************
Getting started
***************
These `tutorials `_ take you step-by-step through some key aspects of django CMS.
*************
Documentation
*************
Our documentation working group maintains documentation for several versions of the project. Key versions are:
* `stable `_ (default), for the **current release** version
* `latest `_, representing the latest build of the **release-3.4.x branch**
* `develop `_, representing the latest build of the **develop branch**
For more information about our branch policy, see `Branches
`_.
Our documentation is hosted courtesy of `Read the Docs `_.
The dependencies for the docs are compiled by `pip-tools `_.
***************************
Test django CMS in our demo
***************************
The demo platform is kindly provided by Divio, platinum member of the django CMS Association.
.. image:: https://raw.githubusercontent.com/django-cms/django-cms/develop/docs/images/try-with-divio.png
:target: https://www.django-cms.org/en/django-cms-demo/
:alt: Try demo with Divio Cloud
************
Getting Help
************
Please head over to our `Slack channel `_ or our `discourse forum `_ for support.
********************
Professional support
********************
Choose from a list of `trusted tech partner `_ of the django CMS Association to get your website project delivered successfully.
Choose a `trusted web host `_ for your django CMS project and get your website online today.
**************************
The django CMS Association
**************************
The django CMS Association is a non-profit organization that was founded in 2020 with the goal to drive the success of django CMS, by increasing customer happiness, market share and open-source contributions. We provide infrastructure and guidance for the django CMS project.
The non-profit django CMS Association is dependent on donations to fulfill its purpose. The best way to donate is to become a member of the association and pay membership fees. The funding will be funneled back into core development and community projects.
`Join the django CMS Association `_.
*******
Credits
*******
* Includes icons from `FamFamFam `_.
* Python tree engine powered by
`django-treebeard `_.
* JavaScript tree in admin uses `jsTree `_.
* Many thanks to
`all the contributors `_
to django CMS!
%prep
%autosetup -n django-cms-3.11.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-cms -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 3.11.1-1
- Package Spec generated