%global _empty_manifest_terminate_build 0
Name: python-pyjson5
Version: 1.6.2
Release: 1
Summary: JSON5 serializer and parser for Python 3 written in Cython.
License: Apache License 2.0
URL: https://github.com/Kijewski/pyjson5
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/69/b3/17e207cface665563321bccf47466be9ea5e446c205137a3bb08952b104d/pyjson5-1.6.2.tar.gz
%description
A JSON5 serializer and parser library for Python 3 written in
`Cython `_.
%package -n python3-pyjson5
Summary: JSON5 serializer and parser for Python 3 written in Cython.
Provides: python-pyjson5
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-pyjson5
A JSON5 serializer and parser library for Python 3 written in
`Cython `_.
%package help
Summary: Development documents and examples for pyjson5
Provides: python3-pyjson5-doc
%description help
A JSON5 serializer and parser library for Python 3 written in
`Cython `_.
%prep
%autosetup -n pyjson5-1.6.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyjson5 -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.6.2-1
- Package Spec generated