%global _empty_manifest_terminate_build 0
Name: python-lightning-bolts
Version: 0.6.0.post1
Release: 1
Summary: Lightning Bolts is a community contribution for ML researchers.
License: Apache-2.0
URL: https://github.com/Lightning-AI/lightning-bolts
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f0/23/0e5e5b5cfc2202f56b48353dc52dc91d3c4b85b09cb6439d996481491d45/lightning-bolts-0.6.0.post1.tar.gz
BuildArch: noarch
Requires: python3-pytorch-lightning
Requires: python3-lightning-utilities
Requires: python3-torchvision
Requires: python3-torchvision
Requires: python3-scikit-learn
Requires: python3-Pillow
Requires: python3-opencv-python-headless
Requires: python3-gym[atari]
Requires: python3-atari-py
Requires: python3-box2d-py
Requires: python3-opencv-python
Requires: python3-matplotlib
Requires: python3-wandb
Requires: python3-scipy
Requires: python3-codecov
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-check-manifest
Requires: python3-pre-commit
Requires: python3-mypy
Requires: python3-atari-py
Requires: python3-scikit-learn
Requires: python3-sparseml
Requires: python3-ale-py
Requires: python3-jsonargparse[signatures]
Requires: python3-torchvision
Requires: python3-scikit-learn
Requires: python3-Pillow
Requires: python3-opencv-python-headless
Requires: python3-gym[atari]
Requires: python3-atari-py
Requires: python3-box2d-py
Requires: python3-opencv-python
Requires: python3-matplotlib
Requires: python3-wandb
Requires: python3-scipy
Requires: python3-matplotlib
Requires: python3-wandb
Requires: python3-scipy
Requires: python3-torchvision
Requires: python3-scikit-learn
Requires: python3-Pillow
Requires: python3-opencv-python-headless
Requires: python3-gym[atari]
Requires: python3-atari-py
Requires: python3-box2d-py
Requires: python3-opencv-python
Requires: python3-codecov
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-check-manifest
Requires: python3-pre-commit
Requires: python3-mypy
Requires: python3-atari-py
Requires: python3-scikit-learn
Requires: python3-sparseml
Requires: python3-ale-py
Requires: python3-jsonargparse[signatures]
%description
**Deep Learning components for extending PyTorch Lightning**
______________________________________________________________________
Installation •
Latest Docs •
Stable Docs •
About •
Community •
Website •
Grid AI •
License
[![PyPI Status](https://badge.fury.io/py/lightning-bolts.svg)](https://badge.fury.io/py/lightning-bolts)
[![PyPI Status](https://pepy.tech/badge/lightning-bolts)](https://pepy.tech/project/lightning-bolts)
[![Build Status](https://dev.azure.com/Lightning-AI/lightning%20Bolts/_apis/build/status/Lightning-AI.lightning-bolts?branchName=master)](https://dev.azure.com/Lightning-AI/lightning%20Bolts/_build?definitionId=31&_a=summary&repositoryFilter=13&branchFilter=4923%2C4923)
[![codecov](https://codecov.io/gh/Lightning-AI/lightning-bolts/release/0.6.0.post1/graph/badge.svg?token=O8p0qhvj90)](https://codecov.io/gh/Lightning-AI/lightning-bolts)
[![Documentation Status](https://readthedocs.org/projects/lightning-bolts/badge/?version=latest)](https://lightning-bolts.readthedocs.io/en/latest/)
[![Slack](https://img.shields.io/badge/slack-chat-green.svg?logo=slack)](https://www.pytorchlightning.ai/community)
[![license](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/PytorchLightning/lightning-bolts/blob/master/LICENSE)
______________________________________________________________________
## Getting Started
Pip / Conda
```bash
pip install lightning-bolts
```
Other installations
Install bleeding-edge (no guarantees)
```bash
pip install git+https://github.com/PytorchLightning/lightning-bolts.git@master --upgrade
```
To install all optional dependencies
```bash
pip install lightning-bolts["extra"]
```
## What is Bolts
Bolts provides a variety of components to extend PyTorch Lightning such as callbacks & datasets, for applied research and production.
## News
- Sept 22: [Leverage Sparsity for Faster Inference with Lightning Flash and SparseML](https://devblog.pytorchlightning.ai/leverage-sparsity-for-faster-inference-with-lightning-flash-and-sparseml-cdda1165622b)
- Aug 26: [Fine-tune Transformers Faster with Lightning Flash and Torch ORT](https://devblog.pytorchlightning.ai/fine-tune-transformers-faster-with-lightning-flash-and-torch-ort-ec2d53789dc3)
#### Example 1: Accelerate Lightning Training with the Torch ORT Callback
Torch ORT converts your model into an optimized ONNX graph, speeding up training & inference when using NVIDIA or AMD GPUs. See the [documentation](https://lightning-bolts.readthedocs.io/en/latest/callbacks/torch_ort.html) for more details.
```python
from pytorch_lightning import LightningModule, Trainer
import torchvision.models as models
from pl_bolts.callbacks import ORTCallback
class VisionModel(LightningModule):
def __init__(self):
super().__init__()
self.model = models.vgg19_bn(pretrained=True)
...
model = VisionModel()
trainer = Trainer(gpus=1, callbacks=ORTCallback())
trainer.fit(model)
```
#### Example 2: Introduce Sparsity with the SparseMLCallback to Accelerate Inference
We can introduce sparsity during fine-tuning with [SparseML](https://github.com/neuralmagic/sparseml), which ultimately allows us to leverage the [DeepSparse](https://github.com/neuralmagic/deepsparse) engine to see performance improvements at inference time.
```python
from pytorch_lightning import LightningModule, Trainer
import torchvision.models as models
from pl_bolts.callbacks import SparseMLCallback
class VisionModel(LightningModule):
def __init__(self):
super().__init__()
self.model = models.vgg19_bn(pretrained=True)
...
model = VisionModel()
trainer = Trainer(gpus=1, callbacks=SparseMLCallback(recipe_path="recipe.yaml"))
trainer.fit(model)
```
## Are specific research implementations supported?
We'd like to encourage users to contribute general components that will help a broad range of problems, however components that help specifics domains will also be welcomed!
For example a callback to help train SSL models would be a great contribution, however the next greatest SSL model from your latest paper would be a good contribution to [Lightning Flash](https://github.com/PyTorchLightning/lightning-flash).
Use [Lightning Flash](https://github.com/PyTorchLightning/lightning-flash) to train, predict and serve state-of-the-art models for applied research. We suggest looking at our [VISSL](https://lightning-flash.readthedocs.io/en/latest/integrations/vissl.html) Flash integration for SSL based tasks.
## Contribute!
Bolts is supported by the PyTorch Lightning team and the PyTorch Lightning community!
Join our Slack and/or read our [CONTRIBUTING](./.github/CONTRIBUTING.md) guidelines to get help becoming a contributor!
______________________________________________________________________
## License
Please observe the Apache 2.0 license that is listed in this repository.
In addition the Lightning framework is Patent Pending.
%package -n python3-lightning-bolts
Summary: Lightning Bolts is a community contribution for ML researchers.
Provides: python-lightning-bolts
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-lightning-bolts
**Deep Learning components for extending PyTorch Lightning**
______________________________________________________________________
Installation •
Latest Docs •
Stable Docs •
About •
Community •
Website •
Grid AI •
License
[![PyPI Status](https://badge.fury.io/py/lightning-bolts.svg)](https://badge.fury.io/py/lightning-bolts)
[![PyPI Status](https://pepy.tech/badge/lightning-bolts)](https://pepy.tech/project/lightning-bolts)
[![Build Status](https://dev.azure.com/Lightning-AI/lightning%20Bolts/_apis/build/status/Lightning-AI.lightning-bolts?branchName=master)](https://dev.azure.com/Lightning-AI/lightning%20Bolts/_build?definitionId=31&_a=summary&repositoryFilter=13&branchFilter=4923%2C4923)
[![codecov](https://codecov.io/gh/Lightning-AI/lightning-bolts/release/0.6.0.post1/graph/badge.svg?token=O8p0qhvj90)](https://codecov.io/gh/Lightning-AI/lightning-bolts)
[![Documentation Status](https://readthedocs.org/projects/lightning-bolts/badge/?version=latest)](https://lightning-bolts.readthedocs.io/en/latest/)
[![Slack](https://img.shields.io/badge/slack-chat-green.svg?logo=slack)](https://www.pytorchlightning.ai/community)
[![license](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/PytorchLightning/lightning-bolts/blob/master/LICENSE)
______________________________________________________________________
## Getting Started
Pip / Conda
```bash
pip install lightning-bolts
```
Other installations
Install bleeding-edge (no guarantees)
```bash
pip install git+https://github.com/PytorchLightning/lightning-bolts.git@master --upgrade
```
To install all optional dependencies
```bash
pip install lightning-bolts["extra"]
```
## What is Bolts
Bolts provides a variety of components to extend PyTorch Lightning such as callbacks & datasets, for applied research and production.
## News
- Sept 22: [Leverage Sparsity for Faster Inference with Lightning Flash and SparseML](https://devblog.pytorchlightning.ai/leverage-sparsity-for-faster-inference-with-lightning-flash-and-sparseml-cdda1165622b)
- Aug 26: [Fine-tune Transformers Faster with Lightning Flash and Torch ORT](https://devblog.pytorchlightning.ai/fine-tune-transformers-faster-with-lightning-flash-and-torch-ort-ec2d53789dc3)
#### Example 1: Accelerate Lightning Training with the Torch ORT Callback
Torch ORT converts your model into an optimized ONNX graph, speeding up training & inference when using NVIDIA or AMD GPUs. See the [documentation](https://lightning-bolts.readthedocs.io/en/latest/callbacks/torch_ort.html) for more details.
```python
from pytorch_lightning import LightningModule, Trainer
import torchvision.models as models
from pl_bolts.callbacks import ORTCallback
class VisionModel(LightningModule):
def __init__(self):
super().__init__()
self.model = models.vgg19_bn(pretrained=True)
...
model = VisionModel()
trainer = Trainer(gpus=1, callbacks=ORTCallback())
trainer.fit(model)
```
#### Example 2: Introduce Sparsity with the SparseMLCallback to Accelerate Inference
We can introduce sparsity during fine-tuning with [SparseML](https://github.com/neuralmagic/sparseml), which ultimately allows us to leverage the [DeepSparse](https://github.com/neuralmagic/deepsparse) engine to see performance improvements at inference time.
```python
from pytorch_lightning import LightningModule, Trainer
import torchvision.models as models
from pl_bolts.callbacks import SparseMLCallback
class VisionModel(LightningModule):
def __init__(self):
super().__init__()
self.model = models.vgg19_bn(pretrained=True)
...
model = VisionModel()
trainer = Trainer(gpus=1, callbacks=SparseMLCallback(recipe_path="recipe.yaml"))
trainer.fit(model)
```
## Are specific research implementations supported?
We'd like to encourage users to contribute general components that will help a broad range of problems, however components that help specifics domains will also be welcomed!
For example a callback to help train SSL models would be a great contribution, however the next greatest SSL model from your latest paper would be a good contribution to [Lightning Flash](https://github.com/PyTorchLightning/lightning-flash).
Use [Lightning Flash](https://github.com/PyTorchLightning/lightning-flash) to train, predict and serve state-of-the-art models for applied research. We suggest looking at our [VISSL](https://lightning-flash.readthedocs.io/en/latest/integrations/vissl.html) Flash integration for SSL based tasks.
## Contribute!
Bolts is supported by the PyTorch Lightning team and the PyTorch Lightning community!
Join our Slack and/or read our [CONTRIBUTING](./.github/CONTRIBUTING.md) guidelines to get help becoming a contributor!
______________________________________________________________________
## License
Please observe the Apache 2.0 license that is listed in this repository.
In addition the Lightning framework is Patent Pending.
%package help
Summary: Development documents and examples for lightning-bolts
Provides: python3-lightning-bolts-doc
%description help
**Deep Learning components for extending PyTorch Lightning**
______________________________________________________________________
Installation •
Latest Docs •
Stable Docs •
About •
Community •
Website •
Grid AI •
License
[![PyPI Status](https://badge.fury.io/py/lightning-bolts.svg)](https://badge.fury.io/py/lightning-bolts)
[![PyPI Status](https://pepy.tech/badge/lightning-bolts)](https://pepy.tech/project/lightning-bolts)
[![Build Status](https://dev.azure.com/Lightning-AI/lightning%20Bolts/_apis/build/status/Lightning-AI.lightning-bolts?branchName=master)](https://dev.azure.com/Lightning-AI/lightning%20Bolts/_build?definitionId=31&_a=summary&repositoryFilter=13&branchFilter=4923%2C4923)
[![codecov](https://codecov.io/gh/Lightning-AI/lightning-bolts/release/0.6.0.post1/graph/badge.svg?token=O8p0qhvj90)](https://codecov.io/gh/Lightning-AI/lightning-bolts)
[![Documentation Status](https://readthedocs.org/projects/lightning-bolts/badge/?version=latest)](https://lightning-bolts.readthedocs.io/en/latest/)
[![Slack](https://img.shields.io/badge/slack-chat-green.svg?logo=slack)](https://www.pytorchlightning.ai/community)
[![license](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/PytorchLightning/lightning-bolts/blob/master/LICENSE)
______________________________________________________________________
## Getting Started
Pip / Conda
```bash
pip install lightning-bolts
```
Other installations
Install bleeding-edge (no guarantees)
```bash
pip install git+https://github.com/PytorchLightning/lightning-bolts.git@master --upgrade
```
To install all optional dependencies
```bash
pip install lightning-bolts["extra"]
```
## What is Bolts
Bolts provides a variety of components to extend PyTorch Lightning such as callbacks & datasets, for applied research and production.
## News
- Sept 22: [Leverage Sparsity for Faster Inference with Lightning Flash and SparseML](https://devblog.pytorchlightning.ai/leverage-sparsity-for-faster-inference-with-lightning-flash-and-sparseml-cdda1165622b)
- Aug 26: [Fine-tune Transformers Faster with Lightning Flash and Torch ORT](https://devblog.pytorchlightning.ai/fine-tune-transformers-faster-with-lightning-flash-and-torch-ort-ec2d53789dc3)
#### Example 1: Accelerate Lightning Training with the Torch ORT Callback
Torch ORT converts your model into an optimized ONNX graph, speeding up training & inference when using NVIDIA or AMD GPUs. See the [documentation](https://lightning-bolts.readthedocs.io/en/latest/callbacks/torch_ort.html) for more details.
```python
from pytorch_lightning import LightningModule, Trainer
import torchvision.models as models
from pl_bolts.callbacks import ORTCallback
class VisionModel(LightningModule):
def __init__(self):
super().__init__()
self.model = models.vgg19_bn(pretrained=True)
...
model = VisionModel()
trainer = Trainer(gpus=1, callbacks=ORTCallback())
trainer.fit(model)
```
#### Example 2: Introduce Sparsity with the SparseMLCallback to Accelerate Inference
We can introduce sparsity during fine-tuning with [SparseML](https://github.com/neuralmagic/sparseml), which ultimately allows us to leverage the [DeepSparse](https://github.com/neuralmagic/deepsparse) engine to see performance improvements at inference time.
```python
from pytorch_lightning import LightningModule, Trainer
import torchvision.models as models
from pl_bolts.callbacks import SparseMLCallback
class VisionModel(LightningModule):
def __init__(self):
super().__init__()
self.model = models.vgg19_bn(pretrained=True)
...
model = VisionModel()
trainer = Trainer(gpus=1, callbacks=SparseMLCallback(recipe_path="recipe.yaml"))
trainer.fit(model)
```
## Are specific research implementations supported?
We'd like to encourage users to contribute general components that will help a broad range of problems, however components that help specifics domains will also be welcomed!
For example a callback to help train SSL models would be a great contribution, however the next greatest SSL model from your latest paper would be a good contribution to [Lightning Flash](https://github.com/PyTorchLightning/lightning-flash).
Use [Lightning Flash](https://github.com/PyTorchLightning/lightning-flash) to train, predict and serve state-of-the-art models for applied research. We suggest looking at our [VISSL](https://lightning-flash.readthedocs.io/en/latest/integrations/vissl.html) Flash integration for SSL based tasks.
## Contribute!
Bolts is supported by the PyTorch Lightning team and the PyTorch Lightning community!
Join our Slack and/or read our [CONTRIBUTING](./.github/CONTRIBUTING.md) guidelines to get help becoming a contributor!
______________________________________________________________________
## License
Please observe the Apache 2.0 license that is listed in this repository.
In addition the Lightning framework is Patent Pending.
%prep
%autosetup -n lightning-bolts-0.6.0.post1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-lightning-bolts -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.6.0.post1-1
- Package Spec generated