%global _empty_manifest_terminate_build 0
Name: python-django-simple-captcha
Version: 0.5.17
Release: 1
Summary: A very simple, yet powerful, Django captcha application
License: MIT
URL: https://github.com/mbi/django-simple-captcha
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/87/22/dfbaf918139b2df374adaad81cb35f188538a54504a7a3796a167a853e6a/django-simple-captcha-0.5.17.tar.gz
BuildArch: noarch
Requires: python3-Django
Requires: python3-Pillow
Requires: python3-django-ranged-response
Requires: python3-testfixtures
%description
*********************
Django Simple Captcha
*********************
.. image:: https://github.com/mbi/django-simple-captcha/actions/workflows/test.yml/badge.svg
:target: https://github.com/mbi/django-simple-captcha/actions/workflows/test.yml
.. image:: https://img.shields.io/pypi/v/django-simple-captcha
:target: https://pypi.org/project/django-simple-captcha/
.. image:: https://img.shields.io/pypi/l/django-simple-captcha
:target: https://github.com/mbi/django-simple-captcha/blob/master/LICENSE
Django Simple Captcha is an extremely simple, yet highly customizable Django application to add captcha images to any Django form.
.. image:: http://django-simple-captcha.readthedocs.io/en/latest/_images/captcha3.png
Features
++++++++
* Very simple to setup and deploy, yet very configurable
* Can use custom challenges (e.g. random chars, simple math, dictionary word, ...)
* Custom generators, noise and filter functions alter the look of the generated image
* Supports text-to-speech audio output of the challenge text, for improved accessibility
* Ajax refresh
Requirements
++++++++++++
* Django 2.2+, Python3.6+
* A recent version of the Pillow compiled with FreeType support
* Flite is required for text-to-speech (audio) output, but not mandatory
Documentation
+++++++++++++
Read the `documentation online `_.
%package -n python3-django-simple-captcha
Summary: A very simple, yet powerful, Django captcha application
Provides: python-django-simple-captcha
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-simple-captcha
*********************
Django Simple Captcha
*********************
.. image:: https://github.com/mbi/django-simple-captcha/actions/workflows/test.yml/badge.svg
:target: https://github.com/mbi/django-simple-captcha/actions/workflows/test.yml
.. image:: https://img.shields.io/pypi/v/django-simple-captcha
:target: https://pypi.org/project/django-simple-captcha/
.. image:: https://img.shields.io/pypi/l/django-simple-captcha
:target: https://github.com/mbi/django-simple-captcha/blob/master/LICENSE
Django Simple Captcha is an extremely simple, yet highly customizable Django application to add captcha images to any Django form.
.. image:: http://django-simple-captcha.readthedocs.io/en/latest/_images/captcha3.png
Features
++++++++
* Very simple to setup and deploy, yet very configurable
* Can use custom challenges (e.g. random chars, simple math, dictionary word, ...)
* Custom generators, noise and filter functions alter the look of the generated image
* Supports text-to-speech audio output of the challenge text, for improved accessibility
* Ajax refresh
Requirements
++++++++++++
* Django 2.2+, Python3.6+
* A recent version of the Pillow compiled with FreeType support
* Flite is required for text-to-speech (audio) output, but not mandatory
Documentation
+++++++++++++
Read the `documentation online `_.
%package help
Summary: Development documents and examples for django-simple-captcha
Provides: python3-django-simple-captcha-doc
%description help
*********************
Django Simple Captcha
*********************
.. image:: https://github.com/mbi/django-simple-captcha/actions/workflows/test.yml/badge.svg
:target: https://github.com/mbi/django-simple-captcha/actions/workflows/test.yml
.. image:: https://img.shields.io/pypi/v/django-simple-captcha
:target: https://pypi.org/project/django-simple-captcha/
.. image:: https://img.shields.io/pypi/l/django-simple-captcha
:target: https://github.com/mbi/django-simple-captcha/blob/master/LICENSE
Django Simple Captcha is an extremely simple, yet highly customizable Django application to add captcha images to any Django form.
.. image:: http://django-simple-captcha.readthedocs.io/en/latest/_images/captcha3.png
Features
++++++++
* Very simple to setup and deploy, yet very configurable
* Can use custom challenges (e.g. random chars, simple math, dictionary word, ...)
* Custom generators, noise and filter functions alter the look of the generated image
* Supports text-to-speech audio output of the challenge text, for improved accessibility
* Ajax refresh
Requirements
++++++++++++
* Django 2.2+, Python3.6+
* A recent version of the Pillow compiled with FreeType support
* Flite is required for text-to-speech (audio) output, but not mandatory
Documentation
+++++++++++++
Read the `documentation online `_.
%prep
%autosetup -n django-simple-captcha-0.5.17
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-simple-captcha -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.5.17-1
- Package Spec generated