%global _empty_manifest_terminate_build 0
Name: python-discord-together
Version: 1.2.6
Release: 1
Summary: Utilize the BETA Discord VC Party Games feature!
License: MIT
URL: https://github.com/apurv-r/discord-together
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b3/7d/b0e91c807b1d02a4c896e0daced1586c0074fbdd92d4fa18295237ea32bf/discord-together-1.2.6.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
%description
Discord Together
Discord has released a BETA feature that they call Discord Party Games or Activities, which allows members to play a large variety of games within a server voice channel. While this feature has officially only been provided to certain hand-picked servers, this module allows you to temporarily enable such features for your servers!
### Use the [docs for discord-together](https://docs.discord-together.ml/) for detailed usage guide.
As of the latest release, this BETA feature is only supported on web and updated PC app versions of Discord and is not supported on mobile.
# 🔩 Installation
## Install [discord-together](https://pypi.org/project/discord-together/)
```
pip install discord-together
```
#### Package dependencies only include [aiohttp](https://pypi.org/project/aiohttp/)
# 🔑 Features
- No specific API wrapper dependencies, works with discord.py and any of its forks
- Easy to use and lightweight
- Actively maintained and updated with latest activites
- Debug mode for invalid invites
# 💻 Code example
This is a simple example of code using this package (with discord.py 1.7.2) to create an invite for a YouTube Watch Together in the channel that the command invoker is currently in.
```py
from discord.ext import commands
from discord_together import DiscordTogether
client = commands.Bot(command_prefix="~")
@client.event
async def on_ready():
client.togetherControl = await DiscordTogether("BOT_TOKEN_HERE")
print('Bot is online!')
@client.command()
async def start(ctx):
link = await client.togetherControl.create_link(ctx.author.voice.channel.id, 'youtube')
await ctx.send(f"Click the blue link!\n{link}")
client.run("BOT_TOKEN_HERE")
```
View the **[docs](https://docs.discord-together.ml/)** for more detailed/advanced examples (like cogs) and explanations!
# 📷 Image
![Invite link](https://cdn.discordapp.com/attachments/678298437854298122/860210951222460446/msedge_Gntg4yflYw.png)
⚠️ Advisory Note:
At least one person needs to click on the BLUE LINK, not the 'Play' button, in order to start the activity! Once the activity is started, people can join by clicking 'Play'.
![YouTube Together](https://cdn.discordapp.com/attachments/678298437854298122/860210751448547328/msedge_HpqALcJCcD.png)
# 🚀 Others
**This package is under MIT license.** Appropriately tested PR's are more than welcome.
*Note: This package is not affiliated with Discord or YouTube.*
If you have any problems or enquiries, join the [discord-together Support Server](https://discord.gg/2fbyXn2hJV) or you can contact me personally on Discord: `Bxllistic#4444`.
This project was converted to support python from the npm package [discord-together](https://www.npmjs.com/package/discord-together)
## **Made with ❤ by Bxllistic**
Credits to [@RemyK888](https://github.com/RemyK888) for initial foundations
%package -n python3-discord-together
Summary: Utilize the BETA Discord VC Party Games feature!
Provides: python-discord-together
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-discord-together
Discord Together
Discord has released a BETA feature that they call Discord Party Games or Activities, which allows members to play a large variety of games within a server voice channel. While this feature has officially only been provided to certain hand-picked servers, this module allows you to temporarily enable such features for your servers!
### Use the [docs for discord-together](https://docs.discord-together.ml/) for detailed usage guide.
As of the latest release, this BETA feature is only supported on web and updated PC app versions of Discord and is not supported on mobile.
# 🔩 Installation
## Install [discord-together](https://pypi.org/project/discord-together/)
```
pip install discord-together
```
#### Package dependencies only include [aiohttp](https://pypi.org/project/aiohttp/)
# 🔑 Features
- No specific API wrapper dependencies, works with discord.py and any of its forks
- Easy to use and lightweight
- Actively maintained and updated with latest activites
- Debug mode for invalid invites
# 💻 Code example
This is a simple example of code using this package (with discord.py 1.7.2) to create an invite for a YouTube Watch Together in the channel that the command invoker is currently in.
```py
from discord.ext import commands
from discord_together import DiscordTogether
client = commands.Bot(command_prefix="~")
@client.event
async def on_ready():
client.togetherControl = await DiscordTogether("BOT_TOKEN_HERE")
print('Bot is online!')
@client.command()
async def start(ctx):
link = await client.togetherControl.create_link(ctx.author.voice.channel.id, 'youtube')
await ctx.send(f"Click the blue link!\n{link}")
client.run("BOT_TOKEN_HERE")
```
View the **[docs](https://docs.discord-together.ml/)** for more detailed/advanced examples (like cogs) and explanations!
# 📷 Image
![Invite link](https://cdn.discordapp.com/attachments/678298437854298122/860210951222460446/msedge_Gntg4yflYw.png)
⚠️ Advisory Note:
At least one person needs to click on the BLUE LINK, not the 'Play' button, in order to start the activity! Once the activity is started, people can join by clicking 'Play'.
![YouTube Together](https://cdn.discordapp.com/attachments/678298437854298122/860210751448547328/msedge_HpqALcJCcD.png)
# 🚀 Others
**This package is under MIT license.** Appropriately tested PR's are more than welcome.
*Note: This package is not affiliated with Discord or YouTube.*
If you have any problems or enquiries, join the [discord-together Support Server](https://discord.gg/2fbyXn2hJV) or you can contact me personally on Discord: `Bxllistic#4444`.
This project was converted to support python from the npm package [discord-together](https://www.npmjs.com/package/discord-together)
## **Made with ❤ by Bxllistic**
Credits to [@RemyK888](https://github.com/RemyK888) for initial foundations
%package help
Summary: Development documents and examples for discord-together
Provides: python3-discord-together-doc
%description help
Discord Together
Discord has released a BETA feature that they call Discord Party Games or Activities, which allows members to play a large variety of games within a server voice channel. While this feature has officially only been provided to certain hand-picked servers, this module allows you to temporarily enable such features for your servers!
### Use the [docs for discord-together](https://docs.discord-together.ml/) for detailed usage guide.
As of the latest release, this BETA feature is only supported on web and updated PC app versions of Discord and is not supported on mobile.
# 🔩 Installation
## Install [discord-together](https://pypi.org/project/discord-together/)
```
pip install discord-together
```
#### Package dependencies only include [aiohttp](https://pypi.org/project/aiohttp/)
# 🔑 Features
- No specific API wrapper dependencies, works with discord.py and any of its forks
- Easy to use and lightweight
- Actively maintained and updated with latest activites
- Debug mode for invalid invites
# 💻 Code example
This is a simple example of code using this package (with discord.py 1.7.2) to create an invite for a YouTube Watch Together in the channel that the command invoker is currently in.
```py
from discord.ext import commands
from discord_together import DiscordTogether
client = commands.Bot(command_prefix="~")
@client.event
async def on_ready():
client.togetherControl = await DiscordTogether("BOT_TOKEN_HERE")
print('Bot is online!')
@client.command()
async def start(ctx):
link = await client.togetherControl.create_link(ctx.author.voice.channel.id, 'youtube')
await ctx.send(f"Click the blue link!\n{link}")
client.run("BOT_TOKEN_HERE")
```
View the **[docs](https://docs.discord-together.ml/)** for more detailed/advanced examples (like cogs) and explanations!
# 📷 Image
![Invite link](https://cdn.discordapp.com/attachments/678298437854298122/860210951222460446/msedge_Gntg4yflYw.png)
⚠️ Advisory Note:
At least one person needs to click on the BLUE LINK, not the 'Play' button, in order to start the activity! Once the activity is started, people can join by clicking 'Play'.
![YouTube Together](https://cdn.discordapp.com/attachments/678298437854298122/860210751448547328/msedge_HpqALcJCcD.png)
# 🚀 Others
**This package is under MIT license.** Appropriately tested PR's are more than welcome.
*Note: This package is not affiliated with Discord or YouTube.*
If you have any problems or enquiries, join the [discord-together Support Server](https://discord.gg/2fbyXn2hJV) or you can contact me personally on Discord: `Bxllistic#4444`.
This project was converted to support python from the npm package [discord-together](https://www.npmjs.com/package/discord-together)
## **Made with ❤ by Bxllistic**
Credits to [@RemyK888](https://github.com/RemyK888) for initial foundations
%prep
%autosetup -n discord-together-1.2.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-discord-together -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.2.6-1
- Package Spec generated