%global _empty_manifest_terminate_build 0 Name: python-pyinfra Version: 2.6.2 Release: 1 Summary: pyinfra automates/provisions/manages/deploys infrastructure. License: MIT URL: https://pyinfra.com Source0: https://mirrors.nju.edu.cn/pypi/web/packages/04/1c/5678b93ff9cc605c6bc1ca346e849cbda69e3541ea22bf3a296742bb0c8d/pyinfra-2.6.2.tar.gz BuildArch: noarch Requires: python3-gevent Requires: python3-paramiko Requires: python3-click Requires: python3-colorama Requires: python3-jinja2 Requires: python3-dateutil Requires: python3-setuptools Requires: python3-configparser Requires: python3-pywinrm Requires: python3-distro Requires: python3-graphlib-backport Requires: python3-pyyaml Requires: python3-pyyaml Requires: python3-pytest-cov Requires: python3-codecov Requires: python3-black Requires: python3-isort Requires: python3-flake8 Requires: python3-flake8-black Requires: python3-flake8-isort Requires: python3-mypy Requires: python3-types-cryptography Requires: python3-types-paramiko Requires: python3-types-python-dateutil Requires: python3-types-PyYAML Requires: python3-types-setuptools Requires: python3-pyinfra-guzzle-sphinx-theme Requires: python3-recommonmark Requires: python3-sphinx Requires: python3-docutils Requires: python3-wheel Requires: python3-twine Requires: python3-ipython Requires: python3-ipdb Requires: python3-ipdbplugin Requires: python3-flake8-spellcheck Requires: python3-redbaron Requires: python3-pytest Requires: python3-coverage Requires: python3-pytest Requires: python3-coverage Requires: python3-pyinfra-guzzle-sphinx-theme Requires: python3-recommonmark Requires: python3-sphinx Requires: python3-docutils Requires: python3-pyyaml Requires: python3-pytest-cov Requires: python3-codecov Requires: python3-black Requires: python3-isort Requires: python3-flake8 Requires: python3-flake8-black Requires: python3-flake8-isort Requires: python3-mypy Requires: python3-types-cryptography Requires: python3-types-paramiko Requires: python3-types-python-dateutil Requires: python3-types-PyYAML Requires: python3-types-setuptools Requires: python3-pytest Requires: python3-coverage Requires: python3-pytest Requires: python3-coverage %description
Documentation ⇒ Getting Started • Examples • Help & Support • Contributing
Chat (both bridged) ⇒
#pyinfra
on Matrix •
Discord
%package -n python3-pyinfra
Summary: pyinfra automates/provisions/manages/deploys infrastructure.
Provides: python-pyinfra
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyinfra
Documentation ⇒ Getting Started • Examples • Help & Support • Contributing
Chat (both bridged) ⇒
#pyinfra
on Matrix •
Discord
%package help
Summary: Development documents and examples for pyinfra
Provides: python3-pyinfra-doc
%description help
Documentation ⇒ Getting Started • Examples • Help & Support • Contributing
Chat (both bridged) ⇒
#pyinfra
on Matrix •
Discord
%prep
%autosetup -n pyinfra-2.6.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyinfra -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot