%global _empty_manifest_terminate_build 0
Name: python-django-referrer-policy
Version: 1.0
Release: 1
Summary: Referrer-Policy header implementation for Django.
License: BSD License
URL: https://github.com/ubernostrum/django-referrer-policy/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e7/ee/f77e38c1e6e9e79ecabb06b7e542aff7fed6971d583d6c482e3d54dffa85/django-referrer-policy-1.0.tar.gz
BuildArch: noarch
%description
.. -*-restructuredtext-*-
.. image:: https://travis-ci.org/ubernostrum/django-referrer-policy.svg?branch=master
:target: https://travis-ci.org/ubernostrum/django-referrer-policy
django-referrer-policy provides a middleware class implementing `the
Referrer-Policy header `_ for
`Django `_-powered sites.
Setting the ``Referrer-Policy`` header allows you to control what, if
any, information is sent in the HTTP ``Referer`` header when a user
clicks a link on your site.
Documentation is `available online
`_.
%package -n python3-django-referrer-policy
Summary: Referrer-Policy header implementation for Django.
Provides: python-django-referrer-policy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-referrer-policy
.. -*-restructuredtext-*-
.. image:: https://travis-ci.org/ubernostrum/django-referrer-policy.svg?branch=master
:target: https://travis-ci.org/ubernostrum/django-referrer-policy
django-referrer-policy provides a middleware class implementing `the
Referrer-Policy header `_ for
`Django `_-powered sites.
Setting the ``Referrer-Policy`` header allows you to control what, if
any, information is sent in the HTTP ``Referer`` header when a user
clicks a link on your site.
Documentation is `available online
`_.
%package help
Summary: Development documents and examples for django-referrer-policy
Provides: python3-django-referrer-policy-doc
%description help
.. -*-restructuredtext-*-
.. image:: https://travis-ci.org/ubernostrum/django-referrer-policy.svg?branch=master
:target: https://travis-ci.org/ubernostrum/django-referrer-policy
django-referrer-policy provides a middleware class implementing `the
Referrer-Policy header `_ for
`Django `_-powered sites.
Setting the ``Referrer-Policy`` header allows you to control what, if
any, information is sent in the HTTP ``Referer`` header when a user
clicks a link on your site.
Documentation is `available online
`_.
%prep
%autosetup -n django-referrer-policy-1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-referrer-policy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.0-1
- Package Spec generated