%global _empty_manifest_terminate_build 0
Name: python-google-cloud-testutils
Version: 1.3.3
Release: 1
Summary: please add a summary manually as the author left a blank one
License: Apache 2.0
URL: https://github.com/googleapis/python-test-utils
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cc/7f/2921a6519e45b1d9299ba18f7599771e0722ccbd5f92112d969cbee65367/google-cloud-testutils-1.3.3.tar.gz
BuildArch: noarch
Requires: python3-google-auth
Requires: python3-click
Requires: python3-packaging
%description
#################
Python Test Utils
#################
This is a collection of common tools used in system tests of Python client libraries for Google APIs.
We use `nox `__ to instrument our tests. This package is added to each `nox` session as described in each repository's ``noxfile.py``.
%package -n python3-google-cloud-testutils
Summary: please add a summary manually as the author left a blank one
Provides: python-google-cloud-testutils
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-google-cloud-testutils
#################
Python Test Utils
#################
This is a collection of common tools used in system tests of Python client libraries for Google APIs.
We use `nox `__ to instrument our tests. This package is added to each `nox` session as described in each repository's ``noxfile.py``.
%package help
Summary: Development documents and examples for google-cloud-testutils
Provides: python3-google-cloud-testutils-doc
%description help
#################
Python Test Utils
#################
This is a collection of common tools used in system tests of Python client libraries for Google APIs.
We use `nox `__ to instrument our tests. This package is added to each `nox` session as described in each repository's ``noxfile.py``.
%prep
%autosetup -n google-cloud-testutils-1.3.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-google-cloud-testutils -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.3.3-1
- Package Spec generated