%global _empty_manifest_terminate_build 0
Name: python-govee-api-laggat
Version: 0.2.2
Release: 1
Summary: Implementation of the govee API to control LED strips and bulbs.
License: MIT License
URL: https://github.com/LaggAt/python-govee-api
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/c0/aca7f6519e7e14bea4db0d1f59c62bd4cd27787e3fa5fa18dc494e965181/govee_api_laggat-0.2.2.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-bios
Requires: python3-certifi
Requires: python3-dacite
Requires: python3-events
Requires: python3-pexpect
Requires: python3-pygatt
%description
# govee-api-laggat Package
Python implementation of the govee API 1.0 to control the cheap and colorful LED strips.
## Why / Motivation
I want to use this package in an Home Assistant Component to control my new light strips.
![demo of custom integration](doc/media/demo_20200920.gif)
Remember: this is NOT the integration, but the library the integration uses.
The custom integration project lives here: [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
## Usage in your project
[Look at the /example folder in this repo.](https://github.com/LaggAt/python-govee-api/tree/master/example)
## Govee trademark
Govee and the Govee logo are trademarks or registered trademarks of Shenzhen Intellirock Company Limited, and used by Govee with permission. Neither your use of the Govee Logo grant you any right, title, or interest in, or any license to reproduce or otherwise use, the Govee logo. You shall not at any time, nor shall you assist others to, challenge Govee's right, title, or interest in, or the validity of, the Govee Marks.
## Links
- PyPi project and python package: [pypi.org/project/govee-api-laggat](https://pypi.org/project/govee-api-laggat/)
- Home Assistant custom integration Git: [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
- Govee API documentation: [Govee API Reference](https://govee-public.s3.amazonaws.com/developer-docs/GoveeAPIReference.pdf)
## API Key
To get an api key you need to install the 'Govee Home' app on your mobile and browse the user tab - About - Request API key. Usually you get your key within seconds by mail.
## Issues / Improvements
There are two projects, this one is the API implementation for python.
The second project is the custom integration into Home Assistant which currently lives [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
Feel free to fork and start a pull request in your feature/bug branch.
If you cannot fix or extend it yourself, you may want to add an issue in the correct project, but it may take a bit longer.
## development
* pip install setuptools wheel tox
* Fork and clone the repository
* Make a 'feature/NAME' or 'bug/NAME' branch
* Run tests: tox
* commit and start a pull request
%package -n python3-govee-api-laggat
Summary: Implementation of the govee API to control LED strips and bulbs.
Provides: python-govee-api-laggat
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-govee-api-laggat
# govee-api-laggat Package
Python implementation of the govee API 1.0 to control the cheap and colorful LED strips.
## Why / Motivation
I want to use this package in an Home Assistant Component to control my new light strips.
![demo of custom integration](doc/media/demo_20200920.gif)
Remember: this is NOT the integration, but the library the integration uses.
The custom integration project lives here: [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
## Usage in your project
[Look at the /example folder in this repo.](https://github.com/LaggAt/python-govee-api/tree/master/example)
## Govee trademark
Govee and the Govee logo are trademarks or registered trademarks of Shenzhen Intellirock Company Limited, and used by Govee with permission. Neither your use of the Govee Logo grant you any right, title, or interest in, or any license to reproduce or otherwise use, the Govee logo. You shall not at any time, nor shall you assist others to, challenge Govee's right, title, or interest in, or the validity of, the Govee Marks.
## Links
- PyPi project and python package: [pypi.org/project/govee-api-laggat](https://pypi.org/project/govee-api-laggat/)
- Home Assistant custom integration Git: [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
- Govee API documentation: [Govee API Reference](https://govee-public.s3.amazonaws.com/developer-docs/GoveeAPIReference.pdf)
## API Key
To get an api key you need to install the 'Govee Home' app on your mobile and browse the user tab - About - Request API key. Usually you get your key within seconds by mail.
## Issues / Improvements
There are two projects, this one is the API implementation for python.
The second project is the custom integration into Home Assistant which currently lives [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
Feel free to fork and start a pull request in your feature/bug branch.
If you cannot fix or extend it yourself, you may want to add an issue in the correct project, but it may take a bit longer.
## development
* pip install setuptools wheel tox
* Fork and clone the repository
* Make a 'feature/NAME' or 'bug/NAME' branch
* Run tests: tox
* commit and start a pull request
%package help
Summary: Development documents and examples for govee-api-laggat
Provides: python3-govee-api-laggat-doc
%description help
# govee-api-laggat Package
Python implementation of the govee API 1.0 to control the cheap and colorful LED strips.
## Why / Motivation
I want to use this package in an Home Assistant Component to control my new light strips.
![demo of custom integration](doc/media/demo_20200920.gif)
Remember: this is NOT the integration, but the library the integration uses.
The custom integration project lives here: [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
## Usage in your project
[Look at the /example folder in this repo.](https://github.com/LaggAt/python-govee-api/tree/master/example)
## Govee trademark
Govee and the Govee logo are trademarks or registered trademarks of Shenzhen Intellirock Company Limited, and used by Govee with permission. Neither your use of the Govee Logo grant you any right, title, or interest in, or any license to reproduce or otherwise use, the Govee logo. You shall not at any time, nor shall you assist others to, challenge Govee's right, title, or interest in, or the validity of, the Govee Marks.
## Links
- PyPi project and python package: [pypi.org/project/govee-api-laggat](https://pypi.org/project/govee-api-laggat/)
- Home Assistant custom integration Git: [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
- Govee API documentation: [Govee API Reference](https://govee-public.s3.amazonaws.com/developer-docs/GoveeAPIReference.pdf)
## API Key
To get an api key you need to install the 'Govee Home' app on your mobile and browse the user tab - About - Request API key. Usually you get your key within seconds by mail.
## Issues / Improvements
There are two projects, this one is the API implementation for python.
The second project is the custom integration into Home Assistant which currently lives [github.com/LaggAt/hacs-govee](https://github.com/LaggAt/hacs-govee)
Feel free to fork and start a pull request in your feature/bug branch.
If you cannot fix or extend it yourself, you may want to add an issue in the correct project, but it may take a bit longer.
## development
* pip install setuptools wheel tox
* Fork and clone the repository
* Make a 'feature/NAME' or 'bug/NAME' branch
* Run tests: tox
* commit and start a pull request
%prep
%autosetup -n govee-api-laggat-0.2.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-govee-api-laggat -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.2.2-1
- Package Spec generated