%global _empty_manifest_terminate_build 0
Name: python-sbase
Version: 4.13.23
Release: 1
Summary: A complete web automation framework for end-to-end testing.
License: MIT
URL: https://github.com/seleniumbase/SeleniumBase
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/44/02/69a229d852a1cbe07a6f8ad0d3aa99ea4469c43674840f9524267fdb6833/sbase-4.13.23.tar.gz
BuildArch: noarch
Requires: python3-seleniumbase
%description
Example: test_coffee_cart.py from ./examples/
```bash
cd examples/
pytest test_coffee_cart.py --demo
```
(--demo
mode slows down tests and highlights actions)
![SeleniumBase Coffee Cart Test SeleniumBase Coffee Cart Test](https://seleniumbase.github.io/cdn/gif/coffee_cart.gif)
* Here's a preview of that test:
```python
from seleniumbase import BaseCase
BaseCase.main(__name__, __file__)
class CoffeeCartTest(BaseCase):
def test_coffee_cart(self):
self.open("https://seleniumbase.io/coffee/")
self.assert_title("Coffee Cart")
self.click('div[data-sb="Cappuccino"]')
self.click('div[data-sb="Flat-White"]')
self.click('div[data-sb="Cafe-Latte"]')
self.click('a[aria-label="Cart page"]')
self.assert_exact_text("Total: $53.00", "button.pay")
self.click("button.pay")
self.type("input#name", "Selenium Coffee")
self.type("input#email", "test@test.test")
self.click("button#submit-payment")
self.assert_text("Thanks for your purchase.", "#app .success")
%package -n python3-sbase
Summary: A complete web automation framework for end-to-end testing.
Provides: python-sbase
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sbase
Example: test_coffee_cart.py from ./examples/
```bash
cd examples/
pytest test_coffee_cart.py --demo
```
(--demo
mode slows down tests and highlights actions)
![SeleniumBase Coffee Cart Test SeleniumBase Coffee Cart Test](https://seleniumbase.github.io/cdn/gif/coffee_cart.gif)
* Here's a preview of that test:
```python
from seleniumbase import BaseCase
BaseCase.main(__name__, __file__)
class CoffeeCartTest(BaseCase):
def test_coffee_cart(self):
self.open("https://seleniumbase.io/coffee/")
self.assert_title("Coffee Cart")
self.click('div[data-sb="Cappuccino"]')
self.click('div[data-sb="Flat-White"]')
self.click('div[data-sb="Cafe-Latte"]')
self.click('a[aria-label="Cart page"]')
self.assert_exact_text("Total: $53.00", "button.pay")
self.click("button.pay")
self.type("input#name", "Selenium Coffee")
self.type("input#email", "test@test.test")
self.click("button#submit-payment")
self.assert_text("Thanks for your purchase.", "#app .success")
%package help
Summary: Development documents and examples for sbase
Provides: python3-sbase-doc
%description help
Example: test_coffee_cart.py from ./examples/
```bash
cd examples/
pytest test_coffee_cart.py --demo
```
(--demo
mode slows down tests and highlights actions)
![SeleniumBase Coffee Cart Test SeleniumBase Coffee Cart Test](https://seleniumbase.github.io/cdn/gif/coffee_cart.gif)
* Here's a preview of that test:
```python
from seleniumbase import BaseCase
BaseCase.main(__name__, __file__)
class CoffeeCartTest(BaseCase):
def test_coffee_cart(self):
self.open("https://seleniumbase.io/coffee/")
self.assert_title("Coffee Cart")
self.click('div[data-sb="Cappuccino"]')
self.click('div[data-sb="Flat-White"]')
self.click('div[data-sb="Cafe-Latte"]')
self.click('a[aria-label="Cart page"]')
self.assert_exact_text("Total: $53.00", "button.pay")
self.click("button.pay")
self.type("input#name", "Selenium Coffee")
self.type("input#email", "test@test.test")
self.click("button#submit-payment")
self.assert_text("Thanks for your purchase.", "#app .success")
%prep
%autosetup -n sbase-4.13.23
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sbase -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 4.13.23-1
- Package Spec generated