%global _empty_manifest_terminate_build 0
Name: python-Optimus
Version: 2.0.0
Release: 1
Summary: Optimus is a static site builder using Jinja2, webassets and Babel.
License: MIT
URL: https://github.com/sveetch/Optimus
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/18/0f/7096f55c39e3d782de1f0ed5466bc132d1171f809aff95d2fc022ca5745d/Optimus-2.0.0.tar.gz
BuildArch: noarch
%description
Optimus is a static site builder, it produces HTML from templates (through `Jinja2`_)
with assets management (through `webassets`_) and i18n support for translations
(through `Babel`_).
Links
*****
* Read the documentation on `Read the docs `_;
* Download its `PyPi package `_;
* Clone it on its `Github repository `_;
%package -n python3-Optimus
Summary: Optimus is a static site builder using Jinja2, webassets and Babel.
Provides: python-Optimus
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Optimus
Optimus is a static site builder, it produces HTML from templates (through `Jinja2`_)
with assets management (through `webassets`_) and i18n support for translations
(through `Babel`_).
Links
*****
* Read the documentation on `Read the docs `_;
* Download its `PyPi package `_;
* Clone it on its `Github repository `_;
%package help
Summary: Development documents and examples for Optimus
Provides: python3-Optimus-doc
%description help
Optimus is a static site builder, it produces HTML from templates (through `Jinja2`_)
with assets management (through `webassets`_) and i18n support for translations
(through `Babel`_).
Links
*****
* Read the documentation on `Read the docs `_;
* Download its `PyPi package `_;
* Clone it on its `Github repository `_;
%prep
%autosetup -n Optimus-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Optimus -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 2.0.0-1
- Package Spec generated