%global _empty_manifest_terminate_build 0
Name: python-MkNxGn-Essentials
Version: 0.1.38
Release: 1
Summary: MkNxGn File Writing, Network Essentials and More - A lot more
License: MIT License
URL: https://mknxgn.com/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/01/bf/836a119a02dbaa5c40e0dc79d7739718f814cc0f073d60c719e96d6c958b/MkNxGn_Essentials-0.1.38.tar.gz
BuildArch: noarch
Requires: python3-netifaces
%description
# mknxgn_essentials
Essentials for python programming.
This is the package we compile essentials code we use in our products that we deem as "essential".
Installing
```
pip3 install mknxng_essentials
```
# What's Inside
## essentials.file_ops
Read and Write Files.
Includes:
Writing JSON files.
Reading JSON files.
Writing 'Soft' encryption files
Reading 'Soft' encryption files
Tar Decompressing
Generating Files of X size in MB
``` python
from essentials import file_ops
```
## essentials.logger_ops
Write Log Files.
Includes:
Debugging with --debug parameter
``` python
from essentials import logger_ops
```
## essentials.run_data
Collects file running data.
Includes:
Argument Parser
File Run Time
``` python
from essentials import run_data
```
## essentials.socket_ops
Socket Engine Note: this item has been depreciated, please use essentials.socket_ops_v2
Includes:
Socket Hosting Server
Socket Connecting Client
WebSocket Support
Multiple Resources to make socketing with python easier
``` python
from essentials import socket_ops
```
## essentials.socket_ops_v2
Socket Engine Note: Documentation for this module is not complete
Includes:
Socket Hosting Server
Socket Connecting Client
WebSocket Support
Multiple Resources to make socketing with python easier
``` python
from essentials import socket_ops_v2
```
## essentials.time_events
Time Events Note: Documentation for this module is not complete
Includes:
Time Event Listener, Calls function when second/minute/hour/day/week/month/year change occurs
``` python
from essentials import time_events
```
## essentials.tokening
Unique Tokening
Includes:
Assemble Token, Assemble a token at (x)Length with predefined or custom characters
Create Token, Create a token at (x)Length with predefined or custom characters and check is it exists in (y), if so, recreate it.
``` python
from essentials import tokening
```
## essentials.search
Search - base for MkNxGn Search Engines
Includes:
Text search - reason; Matches a query to multiple phrases and words and finds the best solution
``` python
from essentials.search import text
```
%package -n python3-MkNxGn-Essentials
Summary: MkNxGn File Writing, Network Essentials and More - A lot more
Provides: python-MkNxGn-Essentials
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-MkNxGn-Essentials
# mknxgn_essentials
Essentials for python programming.
This is the package we compile essentials code we use in our products that we deem as "essential".
Installing
```
pip3 install mknxng_essentials
```
# What's Inside
## essentials.file_ops
Read and Write Files.
Includes:
Writing JSON files.
Reading JSON files.
Writing 'Soft' encryption files
Reading 'Soft' encryption files
Tar Decompressing
Generating Files of X size in MB
``` python
from essentials import file_ops
```
## essentials.logger_ops
Write Log Files.
Includes:
Debugging with --debug parameter
``` python
from essentials import logger_ops
```
## essentials.run_data
Collects file running data.
Includes:
Argument Parser
File Run Time
``` python
from essentials import run_data
```
## essentials.socket_ops
Socket Engine Note: this item has been depreciated, please use essentials.socket_ops_v2
Includes:
Socket Hosting Server
Socket Connecting Client
WebSocket Support
Multiple Resources to make socketing with python easier
``` python
from essentials import socket_ops
```
## essentials.socket_ops_v2
Socket Engine Note: Documentation for this module is not complete
Includes:
Socket Hosting Server
Socket Connecting Client
WebSocket Support
Multiple Resources to make socketing with python easier
``` python
from essentials import socket_ops_v2
```
## essentials.time_events
Time Events Note: Documentation for this module is not complete
Includes:
Time Event Listener, Calls function when second/minute/hour/day/week/month/year change occurs
``` python
from essentials import time_events
```
## essentials.tokening
Unique Tokening
Includes:
Assemble Token, Assemble a token at (x)Length with predefined or custom characters
Create Token, Create a token at (x)Length with predefined or custom characters and check is it exists in (y), if so, recreate it.
``` python
from essentials import tokening
```
## essentials.search
Search - base for MkNxGn Search Engines
Includes:
Text search - reason; Matches a query to multiple phrases and words and finds the best solution
``` python
from essentials.search import text
```
%package help
Summary: Development documents and examples for MkNxGn-Essentials
Provides: python3-MkNxGn-Essentials-doc
%description help
# mknxgn_essentials
Essentials for python programming.
This is the package we compile essentials code we use in our products that we deem as "essential".
Installing
```
pip3 install mknxng_essentials
```
# What's Inside
## essentials.file_ops
Read and Write Files.
Includes:
Writing JSON files.
Reading JSON files.
Writing 'Soft' encryption files
Reading 'Soft' encryption files
Tar Decompressing
Generating Files of X size in MB
``` python
from essentials import file_ops
```
## essentials.logger_ops
Write Log Files.
Includes:
Debugging with --debug parameter
``` python
from essentials import logger_ops
```
## essentials.run_data
Collects file running data.
Includes:
Argument Parser
File Run Time
``` python
from essentials import run_data
```
## essentials.socket_ops
Socket Engine Note: this item has been depreciated, please use essentials.socket_ops_v2
Includes:
Socket Hosting Server
Socket Connecting Client
WebSocket Support
Multiple Resources to make socketing with python easier
``` python
from essentials import socket_ops
```
## essentials.socket_ops_v2
Socket Engine Note: Documentation for this module is not complete
Includes:
Socket Hosting Server
Socket Connecting Client
WebSocket Support
Multiple Resources to make socketing with python easier
``` python
from essentials import socket_ops_v2
```
## essentials.time_events
Time Events Note: Documentation for this module is not complete
Includes:
Time Event Listener, Calls function when second/minute/hour/day/week/month/year change occurs
``` python
from essentials import time_events
```
## essentials.tokening
Unique Tokening
Includes:
Assemble Token, Assemble a token at (x)Length with predefined or custom characters
Create Token, Create a token at (x)Length with predefined or custom characters and check is it exists in (y), if so, recreate it.
``` python
from essentials import tokening
```
## essentials.search
Search - base for MkNxGn Search Engines
Includes:
Text search - reason; Matches a query to multiple phrases and words and finds the best solution
``` python
from essentials.search import text
```
%prep
%autosetup -n MkNxGn-Essentials-0.1.38
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-MkNxGn-Essentials -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.1.38-1
- Package Spec generated