%global _empty_manifest_terminate_build 0
Name: python-vk
Version: 3.0
Release: 1
Summary: Python vk.com API wrapper
License: MIT
URL: https://github.com/voronind/vk
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c1/c7/7593fa1d3945db3f3b2281d074d7d4a977713a8f0a3c34e1ea7edd29fef5/vk-3.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-sphinx
Requires: python3-sphinx-autobuild
Requires: python3-sphinx-rtd-theme
Requires: python3-pytest
Requires: python3-pytest-cov
%description
# vk | python vk.com API wrapper
[![Maintanance](https://img.shields.io/maintenance/yes/2022?style=flat-square)](https://github.com/voronind/vk/commits/master)
[![PyPI](https://img.shields.io/pypi/pyversions/vk?style=flat-square)](https://pypi.org/project/vk/)
[![GitHub CI](https://img.shields.io/github/workflow/status/voronind/vk/Check/master?style=flat-square)](https://github.com/voronind/vk/actions)
[![Codecov](https://img.shields.io/codecov/c/github/voronind/vk?style=flat-square)](https://codecov.io/gh/voronind/vk)
[![Docs](https://img.shields.io/readthedocs/vk?style=flat-square)](https://vk.readthedocs.io/en/latest/)
This is a vk.com (the largest Russian social network) python API wrapper.
The goal is to support all API methods (current and future) that can be accessed from server.
## Quickstart
### Install
```bash
pip install vk
```
### Usage
```python
>>> import vk
>>> api = vk.API(access_token='...')
>>> api.users.get(user_ids=1)
[{'id': 1, 'first_name': 'Pavel', 'last_name': 'Durov', ... }]
```
See official VK [documentation](https://dev.vk.com/method) for detailed API guide.
## More info
Read full documentation on [Read the Docs](https://vk.readthedocs.org)
%package -n python3-vk
Summary: Python vk.com API wrapper
Provides: python-vk
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-vk
# vk | python vk.com API wrapper
[![Maintanance](https://img.shields.io/maintenance/yes/2022?style=flat-square)](https://github.com/voronind/vk/commits/master)
[![PyPI](https://img.shields.io/pypi/pyversions/vk?style=flat-square)](https://pypi.org/project/vk/)
[![GitHub CI](https://img.shields.io/github/workflow/status/voronind/vk/Check/master?style=flat-square)](https://github.com/voronind/vk/actions)
[![Codecov](https://img.shields.io/codecov/c/github/voronind/vk?style=flat-square)](https://codecov.io/gh/voronind/vk)
[![Docs](https://img.shields.io/readthedocs/vk?style=flat-square)](https://vk.readthedocs.io/en/latest/)
This is a vk.com (the largest Russian social network) python API wrapper.
The goal is to support all API methods (current and future) that can be accessed from server.
## Quickstart
### Install
```bash
pip install vk
```
### Usage
```python
>>> import vk
>>> api = vk.API(access_token='...')
>>> api.users.get(user_ids=1)
[{'id': 1, 'first_name': 'Pavel', 'last_name': 'Durov', ... }]
```
See official VK [documentation](https://dev.vk.com/method) for detailed API guide.
## More info
Read full documentation on [Read the Docs](https://vk.readthedocs.org)
%package help
Summary: Development documents and examples for vk
Provides: python3-vk-doc
%description help
# vk | python vk.com API wrapper
[![Maintanance](https://img.shields.io/maintenance/yes/2022?style=flat-square)](https://github.com/voronind/vk/commits/master)
[![PyPI](https://img.shields.io/pypi/pyversions/vk?style=flat-square)](https://pypi.org/project/vk/)
[![GitHub CI](https://img.shields.io/github/workflow/status/voronind/vk/Check/master?style=flat-square)](https://github.com/voronind/vk/actions)
[![Codecov](https://img.shields.io/codecov/c/github/voronind/vk?style=flat-square)](https://codecov.io/gh/voronind/vk)
[![Docs](https://img.shields.io/readthedocs/vk?style=flat-square)](https://vk.readthedocs.io/en/latest/)
This is a vk.com (the largest Russian social network) python API wrapper.
The goal is to support all API methods (current and future) that can be accessed from server.
## Quickstart
### Install
```bash
pip install vk
```
### Usage
```python
>>> import vk
>>> api = vk.API(access_token='...')
>>> api.users.get(user_ids=1)
[{'id': 1, 'first_name': 'Pavel', 'last_name': 'Durov', ... }]
```
See official VK [documentation](https://dev.vk.com/method) for detailed API guide.
## More info
Read full documentation on [Read the Docs](https://vk.readthedocs.org)
%prep
%autosetup -n vk-3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-vk -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 3.0-1
- Package Spec generated