%global _empty_manifest_terminate_build 0
Name: python-pypickle
Version: 1.1.0
Release: 1
Summary: pypickle is to save and load variables in/from pickle files
License: MIT License
URL: https://github.com/erdogant/pypickle
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f6/4e/48d0d9046cc58b3b3473a14fe32d224fa76af716cbc1db8756010d84981f/pypickle-1.1.0.tar.gz
BuildArch: noarch
%description
# pypickle
[](https://img.shields.io/pypi/pyversions/pypickle)
[](https://pypi.org/project/pypickle/)
[](https://github.com/erdogant/pypickle/blob/master/LICENSE)
[](https://pepy.tech/project/pypickle)
[](https://pepy.tech/project/pypickle/)
[](https://zenodo.org/badge/latestdoi/278702058)
[](https://erdogant.github.io/pypickle/)
* pypickle is for saving data and loading the files in pickle format.
#
**⭐️ Star this repo if you like it ⭐️**
#
### [Documentation pages](https://erdogant.github.io/pypickle/)
On the [documentation pages](https://erdogant.github.io/pypickle/) you can find more information about ``pypickle`` with examples.
#
##### Install bnlearn from PyPI
```bash
pip install pypickle # normal install
pip install -U pypickle # update if needed
```
#### Import pypickle package
```python
import pypickle
```
#
#### [Example: Saving](https://erdogant.github.io/pypickle/pages/html/Save_and_Load.html#saving)
```python
import pypickle
filepath = 'test.pkl'
# Some data
data = [1,2,3,4,5]
# Save
status = pypickle.save(filepath, data)
```
#
#### [Example: Loading](https://erdogant.github.io/pypickle/pages/html/Save_and_Load.html#loading)
```python
# Load file
data = pypickle.load(filepath)
```
### Contribute
* All kinds of contributions are welcome!
### Citation
Please cite pypickle in your publications if this is useful for your research. See column right for citation information.
### Maintainer
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
* Contributions are welcome.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
%package -n python3-pypickle
Summary: pypickle is to save and load variables in/from pickle files
Provides: python-pypickle
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pypickle
# pypickle
[](https://img.shields.io/pypi/pyversions/pypickle)
[](https://pypi.org/project/pypickle/)
[](https://github.com/erdogant/pypickle/blob/master/LICENSE)
[](https://pepy.tech/project/pypickle)
[](https://pepy.tech/project/pypickle/)
[](https://zenodo.org/badge/latestdoi/278702058)
[](https://erdogant.github.io/pypickle/)
* pypickle is for saving data and loading the files in pickle format.
#
**⭐️ Star this repo if you like it ⭐️**
#
### [Documentation pages](https://erdogant.github.io/pypickle/)
On the [documentation pages](https://erdogant.github.io/pypickle/) you can find more information about ``pypickle`` with examples.
#
##### Install bnlearn from PyPI
```bash
pip install pypickle # normal install
pip install -U pypickle # update if needed
```
#### Import pypickle package
```python
import pypickle
```
#
#### [Example: Saving](https://erdogant.github.io/pypickle/pages/html/Save_and_Load.html#saving)
```python
import pypickle
filepath = 'test.pkl'
# Some data
data = [1,2,3,4,5]
# Save
status = pypickle.save(filepath, data)
```
#
#### [Example: Loading](https://erdogant.github.io/pypickle/pages/html/Save_and_Load.html#loading)
```python
# Load file
data = pypickle.load(filepath)
```
### Contribute
* All kinds of contributions are welcome!
### Citation
Please cite pypickle in your publications if this is useful for your research. See column right for citation information.
### Maintainer
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
* Contributions are welcome.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
%package help
Summary: Development documents and examples for pypickle
Provides: python3-pypickle-doc
%description help
# pypickle
[](https://img.shields.io/pypi/pyversions/pypickle)
[](https://pypi.org/project/pypickle/)
[](https://github.com/erdogant/pypickle/blob/master/LICENSE)
[](https://pepy.tech/project/pypickle)
[](https://pepy.tech/project/pypickle/)
[](https://zenodo.org/badge/latestdoi/278702058)
[](https://erdogant.github.io/pypickle/)
* pypickle is for saving data and loading the files in pickle format.
#
**⭐️ Star this repo if you like it ⭐️**
#
### [Documentation pages](https://erdogant.github.io/pypickle/)
On the [documentation pages](https://erdogant.github.io/pypickle/) you can find more information about ``pypickle`` with examples.
#
##### Install bnlearn from PyPI
```bash
pip install pypickle # normal install
pip install -U pypickle # update if needed
```
#### Import pypickle package
```python
import pypickle
```
#
#### [Example: Saving](https://erdogant.github.io/pypickle/pages/html/Save_and_Load.html#saving)
```python
import pypickle
filepath = 'test.pkl'
# Some data
data = [1,2,3,4,5]
# Save
status = pypickle.save(filepath, data)
```
#
#### [Example: Loading](https://erdogant.github.io/pypickle/pages/html/Save_and_Load.html#loading)
```python
# Load file
data = pypickle.load(filepath)
```
### Contribute
* All kinds of contributions are welcome!
### Citation
Please cite pypickle in your publications if this is useful for your research. See column right for citation information.
### Maintainer
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
* Contributions are welcome.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
%prep
%autosetup -n pypickle-1.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pypickle -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.1.0-1
- Package Spec generated