%global _empty_manifest_terminate_build 0
Name: python-bioversions
Version: 0.5.102
Release: 1
Summary: What's the current version for each biological database?
License: MIT
URL: https://github.com/biopragmatics/bioversions
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2a/d7/dc56d68bb4f5bda78583b96e81fcff2db87fb430c03ca0e7f197f9c8ad4e/bioversions-0.5.102.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-requests-ftp
Requires: python3-beautifulsoup4
Requires: python3-cachier
Requires: python3-pystow
Requires: python3-click
Requires: python3-click-default-group
Requires: python3-dataclasses-json
Requires: python3-tabulate
Requires: python3-more-click
Requires: python3-pyyaml
Requires: python3-tqdm
Requires: python3-bioregistry[align]
Requires: python3-lxml
Requires: python3-psycopg2-binary
Requires: python3-matplotlib
Requires: python3-seaborn
Requires: python3-slack-sdk
Requires: python3-tweepy
Requires: python3-flask
Requires: python3-bootstrap-flask
%description
Bioversions
What's the current version for each biological database?
A daily updated static listing of all current versions (that are incorporated) can be found at
https://biopragmatics.github.io/bioversions.
## 🚀 Installation
```bash
$ pip install bioversions
```
## 💪 Usage
```python
import bioversions
assert bioversions.get_version('biogrid') == '4.2.192', 'This was true on Dec 5th, 2020!'
# If you want more information, use the resolve() function
bioversion = bioversions.resolve('biogrid')
assert bioversion.version == '4.2.192'
```
By default, the results are cached and only refreshed once per day with the help
of [`cachier`](https://github.com/shaypal5/cachier). The cache is stored in `~/.data/bioversions`. The cache location
can be overridden by setting the
`BIOVERSIONS_HOME` environment variable via [`pystow`](https://github.com/cthoyt/pystow).
## 🌐 Web Application
While https://biopragmatics.github.io/bioversions provides a daily updated static listing of the database, you can run a
dynamic version with an API from your shell with:
```bash
$ bioversions web
```
Options can be listed with `bioversions web --help`.
You can navigate to http://localhost:5000 to see all versions as HTML or programmatically resolve given databases with
the
`http://localhost:5000/database/` endpoint like in the following:
```python
import requests
res = requests.get('http://localhost:5000/database/biogrid').json()
assert res['success']
assert res['result']['name'] == 'BioGRID'
assert res['result']['version'] == '4.2.192', 'This was true on Dec 5th, 2020!'
```
## CLI Usage
You can use `bioversions get` to incorporate the latest versions in your shell scripts or REPL usage like in:
```bash
$ wget "https://downloads.thebiogrid.org/Download/BioGRID/Release-Archive/BIOGRID-$(bioversions get biogrid)/BIOGRID-ALL-$(bioversions get biogrid).mitab.zip"
```
## 🙏 Contributing
To add more databases to the list, you can create a new submodule of
`bioversions.sources` and extend the `bioversions.utils.Getter` class to identify the most recent version for your
target database. See
`bioversions.sources.biogrid` as an example.
## 👋 Attribution
### ⚖️ License
Code is licensed under the MIT License.
### 🎁 Support
The Bioversions service was developed by the [INDRA Lab](https://indralab.github.io), a part of the
[Laboratory of Systems Pharmacology](https://hits.harvard.edu/the-program/laboratory-of-systems-pharmacology/about/)
and the [Harvard Program in Therapeutic Science (HiTS)](https://hits.harvard.edu)
at [Harvard Medical School](https://hms.harvard.edu/).
### 💰 Funding
The development of the Bioregistry is funded by the DARPA Young Faculty Award W911NF2010255 (PI:
Benjamin M. Gyori).
%package -n python3-bioversions
Summary: What's the current version for each biological database?
Provides: python-bioversions
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bioversions
Bioversions
What's the current version for each biological database?
A daily updated static listing of all current versions (that are incorporated) can be found at
https://biopragmatics.github.io/bioversions.
## 🚀 Installation
```bash
$ pip install bioversions
```
## 💪 Usage
```python
import bioversions
assert bioversions.get_version('biogrid') == '4.2.192', 'This was true on Dec 5th, 2020!'
# If you want more information, use the resolve() function
bioversion = bioversions.resolve('biogrid')
assert bioversion.version == '4.2.192'
```
By default, the results are cached and only refreshed once per day with the help
of [`cachier`](https://github.com/shaypal5/cachier). The cache is stored in `~/.data/bioversions`. The cache location
can be overridden by setting the
`BIOVERSIONS_HOME` environment variable via [`pystow`](https://github.com/cthoyt/pystow).
## 🌐 Web Application
While https://biopragmatics.github.io/bioversions provides a daily updated static listing of the database, you can run a
dynamic version with an API from your shell with:
```bash
$ bioversions web
```
Options can be listed with `bioversions web --help`.
You can navigate to http://localhost:5000 to see all versions as HTML or programmatically resolve given databases with
the
`http://localhost:5000/database/` endpoint like in the following:
```python
import requests
res = requests.get('http://localhost:5000/database/biogrid').json()
assert res['success']
assert res['result']['name'] == 'BioGRID'
assert res['result']['version'] == '4.2.192', 'This was true on Dec 5th, 2020!'
```
## CLI Usage
You can use `bioversions get` to incorporate the latest versions in your shell scripts or REPL usage like in:
```bash
$ wget "https://downloads.thebiogrid.org/Download/BioGRID/Release-Archive/BIOGRID-$(bioversions get biogrid)/BIOGRID-ALL-$(bioversions get biogrid).mitab.zip"
```
## 🙏 Contributing
To add more databases to the list, you can create a new submodule of
`bioversions.sources` and extend the `bioversions.utils.Getter` class to identify the most recent version for your
target database. See
`bioversions.sources.biogrid` as an example.
## 👋 Attribution
### ⚖️ License
Code is licensed under the MIT License.
### 🎁 Support
The Bioversions service was developed by the [INDRA Lab](https://indralab.github.io), a part of the
[Laboratory of Systems Pharmacology](https://hits.harvard.edu/the-program/laboratory-of-systems-pharmacology/about/)
and the [Harvard Program in Therapeutic Science (HiTS)](https://hits.harvard.edu)
at [Harvard Medical School](https://hms.harvard.edu/).
### 💰 Funding
The development of the Bioregistry is funded by the DARPA Young Faculty Award W911NF2010255 (PI:
Benjamin M. Gyori).
%package help
Summary: Development documents and examples for bioversions
Provides: python3-bioversions-doc
%description help
Bioversions
What's the current version for each biological database?
A daily updated static listing of all current versions (that are incorporated) can be found at
https://biopragmatics.github.io/bioversions.
## 🚀 Installation
```bash
$ pip install bioversions
```
## 💪 Usage
```python
import bioversions
assert bioversions.get_version('biogrid') == '4.2.192', 'This was true on Dec 5th, 2020!'
# If you want more information, use the resolve() function
bioversion = bioversions.resolve('biogrid')
assert bioversion.version == '4.2.192'
```
By default, the results are cached and only refreshed once per day with the help
of [`cachier`](https://github.com/shaypal5/cachier). The cache is stored in `~/.data/bioversions`. The cache location
can be overridden by setting the
`BIOVERSIONS_HOME` environment variable via [`pystow`](https://github.com/cthoyt/pystow).
## 🌐 Web Application
While https://biopragmatics.github.io/bioversions provides a daily updated static listing of the database, you can run a
dynamic version with an API from your shell with:
```bash
$ bioversions web
```
Options can be listed with `bioversions web --help`.
You can navigate to http://localhost:5000 to see all versions as HTML or programmatically resolve given databases with
the
`http://localhost:5000/database/` endpoint like in the following:
```python
import requests
res = requests.get('http://localhost:5000/database/biogrid').json()
assert res['success']
assert res['result']['name'] == 'BioGRID'
assert res['result']['version'] == '4.2.192', 'This was true on Dec 5th, 2020!'
```
## CLI Usage
You can use `bioversions get` to incorporate the latest versions in your shell scripts or REPL usage like in:
```bash
$ wget "https://downloads.thebiogrid.org/Download/BioGRID/Release-Archive/BIOGRID-$(bioversions get biogrid)/BIOGRID-ALL-$(bioversions get biogrid).mitab.zip"
```
## 🙏 Contributing
To add more databases to the list, you can create a new submodule of
`bioversions.sources` and extend the `bioversions.utils.Getter` class to identify the most recent version for your
target database. See
`bioversions.sources.biogrid` as an example.
## 👋 Attribution
### ⚖️ License
Code is licensed under the MIT License.
### 🎁 Support
The Bioversions service was developed by the [INDRA Lab](https://indralab.github.io), a part of the
[Laboratory of Systems Pharmacology](https://hits.harvard.edu/the-program/laboratory-of-systems-pharmacology/about/)
and the [Harvard Program in Therapeutic Science (HiTS)](https://hits.harvard.edu)
at [Harvard Medical School](https://hms.harvard.edu/).
### 💰 Funding
The development of the Bioregistry is funded by the DARPA Young Faculty Award W911NF2010255 (PI:
Benjamin M. Gyori).
%prep
%autosetup -n bioversions-0.5.102
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bioversions -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 0.5.102-1
- Package Spec generated