%global _empty_manifest_terminate_build 0
Name: python-Cartopy
Version: 0.21.1
Release: 1
Summary: A cartographic python library with Matplotlib support for visualisation
License: LGPLv3
URL: https://scitools.org.uk/cartopy/docs/latest/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e8/11/ed3e364b3910f0951821e6b5a03a03ce425464b72aa3da08d47b78ae17bd/Cartopy-0.21.1.tar.gz
BuildArch: noarch
%description
Cartopy is a Python package designed to make drawing maps for
data analysis and visualisation easy.
# Table of contents
- [Overview](#overview)
- [Get in touch](#get-in-touch)
- [License and copyright](#license-and-copyright)
## Overview
Cartopy is a Python package designed to make drawing maps for data
analysis and visualisation easy.
It features:
- object oriented projection definitions
- point, line, polygon and image transformations between projections
- integration to expose advanced mapping in Matplotlib with a simple and
intuitive interface
- powerful vector data handling by integrating shapefile reading with Shapely
capabilities
Documentation can be found at .
## Get in touch
- Ask usage questions on
[StackOverflow](https://stackoverflow.com/questions/tagged/cartopy).
- For less well defined questions, ideas, general discussion or announcements
of related projects use the
[Google Group](https://groups.google.com/forum/#!forum/scitools-iris).
- Report bugs, suggest features or view the source code on
[GitHub](https://github.com/SciTools/cartopy).
- To chat with developers and other users you can use the
[Gitter Chat](https://gitter.im/SciTools/cartopy)
## Credits, copyright and license
Cartopy is developed collaboratively under the SciTools umberella.
A full list of codecontributors ("Cartopy contributors") can be found at
https://github.com/SciTools/cartopy/graphs/contributors.
Code is just one of many ways of positively contributing to Cartopy, please see
our [contributing guide](.github/CONTRIBUTING.md) for more details on how
you can get involved.
Cartopy is released under a LGPL license with a shared copyright model.
See [COPYING](COPYING) and [COPYING.LESSER](COPYING.LESSER) for full terms.
The [Met Office](https://metoffice.gov.uk) has made a significant
contribution to the development, maintenance and support of this library.
All Met Office contributions are copyright on behalf of the British Crown.
%package -n python3-Cartopy
Summary: A cartographic python library with Matplotlib support for visualisation
Provides: python-Cartopy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Cartopy
Cartopy is a Python package designed to make drawing maps for
data analysis and visualisation easy.
# Table of contents
- [Overview](#overview)
- [Get in touch](#get-in-touch)
- [License and copyright](#license-and-copyright)
## Overview
Cartopy is a Python package designed to make drawing maps for data
analysis and visualisation easy.
It features:
- object oriented projection definitions
- point, line, polygon and image transformations between projections
- integration to expose advanced mapping in Matplotlib with a simple and
intuitive interface
- powerful vector data handling by integrating shapefile reading with Shapely
capabilities
Documentation can be found at .
## Get in touch
- Ask usage questions on
[StackOverflow](https://stackoverflow.com/questions/tagged/cartopy).
- For less well defined questions, ideas, general discussion or announcements
of related projects use the
[Google Group](https://groups.google.com/forum/#!forum/scitools-iris).
- Report bugs, suggest features or view the source code on
[GitHub](https://github.com/SciTools/cartopy).
- To chat with developers and other users you can use the
[Gitter Chat](https://gitter.im/SciTools/cartopy)
## Credits, copyright and license
Cartopy is developed collaboratively under the SciTools umberella.
A full list of codecontributors ("Cartopy contributors") can be found at
https://github.com/SciTools/cartopy/graphs/contributors.
Code is just one of many ways of positively contributing to Cartopy, please see
our [contributing guide](.github/CONTRIBUTING.md) for more details on how
you can get involved.
Cartopy is released under a LGPL license with a shared copyright model.
See [COPYING](COPYING) and [COPYING.LESSER](COPYING.LESSER) for full terms.
The [Met Office](https://metoffice.gov.uk) has made a significant
contribution to the development, maintenance and support of this library.
All Met Office contributions are copyright on behalf of the British Crown.
%package help
Summary: Development documents and examples for Cartopy
Provides: python3-Cartopy-doc
%description help
Cartopy is a Python package designed to make drawing maps for
data analysis and visualisation easy.
# Table of contents
- [Overview](#overview)
- [Get in touch](#get-in-touch)
- [License and copyright](#license-and-copyright)
## Overview
Cartopy is a Python package designed to make drawing maps for data
analysis and visualisation easy.
It features:
- object oriented projection definitions
- point, line, polygon and image transformations between projections
- integration to expose advanced mapping in Matplotlib with a simple and
intuitive interface
- powerful vector data handling by integrating shapefile reading with Shapely
capabilities
Documentation can be found at .
## Get in touch
- Ask usage questions on
[StackOverflow](https://stackoverflow.com/questions/tagged/cartopy).
- For less well defined questions, ideas, general discussion or announcements
of related projects use the
[Google Group](https://groups.google.com/forum/#!forum/scitools-iris).
- Report bugs, suggest features or view the source code on
[GitHub](https://github.com/SciTools/cartopy).
- To chat with developers and other users you can use the
[Gitter Chat](https://gitter.im/SciTools/cartopy)
## Credits, copyright and license
Cartopy is developed collaboratively under the SciTools umberella.
A full list of codecontributors ("Cartopy contributors") can be found at
https://github.com/SciTools/cartopy/graphs/contributors.
Code is just one of many ways of positively contributing to Cartopy, please see
our [contributing guide](.github/CONTRIBUTING.md) for more details on how
you can get involved.
Cartopy is released under a LGPL license with a shared copyright model.
See [COPYING](COPYING) and [COPYING.LESSER](COPYING.LESSER) for full terms.
The [Met Office](https://metoffice.gov.uk) has made a significant
contribution to the development, maintenance and support of this library.
All Met Office contributions are copyright on behalf of the British Crown.
%prep
%autosetup -n Cartopy-0.21.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Cartopy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.21.1-1
- Package Spec generated