%global _empty_manifest_terminate_build 0
Name: python-cytoolz
Version: 0.12.1
Release: 1
Summary: Cython implementation of Toolz: High performance functional utilities
License: BSD
URL: https://github.com/pytoolz/cytoolz
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/da/89/66bac516a236af8375dd7af2b3032a210e222395670758da4b2439b37e40/cytoolz-0.12.1.tar.gz
Requires: python3-toolz
Requires: python3-cython
%description
|Build Status| |Version Status|
Cython implementation of the
|literal toolz|_ `package, `__ which
provides high performance utility functions for iterables, functions,
and dictionaries.
``toolz`` is a pure Python package that borrows heavily from contemporary
functional languanges. It is designed to interoperate seamlessly with other
libraries including ``itertools``, ``functools``, and third party libraries.
High performance functional data analysis is possible with builtin types
like ``list`` and ``dict``, and user-defined data structures; and low memory
usage is achieved by using the iterator protocol and returning iterators
whenever possible.
``cytoolz`` implements the same API as ``toolz``. The main differences are
that ``cytoolz`` is faster (typically 2-5x faster with a few spectacular
exceptions) and ``cytoolz`` offers a C API that is accessible to other
projects developed in Cython. Since ``toolz`` is able to process very
large (potentially infinite) data sets, the performance increase gained by
using ``cytoolz`` can be significant.
See the PyToolz documentation at https://toolz.readthedocs.io and the full
`API Documentation `__
for more details.
%package -n python3-cytoolz
Summary: Cython implementation of Toolz: High performance functional utilities
Provides: python-cytoolz
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-cytoolz
|Build Status| |Version Status|
Cython implementation of the
|literal toolz|_ `package, `__ which
provides high performance utility functions for iterables, functions,
and dictionaries.
``toolz`` is a pure Python package that borrows heavily from contemporary
functional languanges. It is designed to interoperate seamlessly with other
libraries including ``itertools``, ``functools``, and third party libraries.
High performance functional data analysis is possible with builtin types
like ``list`` and ``dict``, and user-defined data structures; and low memory
usage is achieved by using the iterator protocol and returning iterators
whenever possible.
``cytoolz`` implements the same API as ``toolz``. The main differences are
that ``cytoolz`` is faster (typically 2-5x faster with a few spectacular
exceptions) and ``cytoolz`` offers a C API that is accessible to other
projects developed in Cython. Since ``toolz`` is able to process very
large (potentially infinite) data sets, the performance increase gained by
using ``cytoolz`` can be significant.
See the PyToolz documentation at https://toolz.readthedocs.io and the full
`API Documentation `__
for more details.
%package help
Summary: Development documents and examples for cytoolz
Provides: python3-cytoolz-doc
%description help
|Build Status| |Version Status|
Cython implementation of the
|literal toolz|_ `package, `__ which
provides high performance utility functions for iterables, functions,
and dictionaries.
``toolz`` is a pure Python package that borrows heavily from contemporary
functional languanges. It is designed to interoperate seamlessly with other
libraries including ``itertools``, ``functools``, and third party libraries.
High performance functional data analysis is possible with builtin types
like ``list`` and ``dict``, and user-defined data structures; and low memory
usage is achieved by using the iterator protocol and returning iterators
whenever possible.
``cytoolz`` implements the same API as ``toolz``. The main differences are
that ``cytoolz`` is faster (typically 2-5x faster with a few spectacular
exceptions) and ``cytoolz`` offers a C API that is accessible to other
projects developed in Cython. Since ``toolz`` is able to process very
large (potentially infinite) data sets, the performance increase gained by
using ``cytoolz`` can be significant.
See the PyToolz documentation at https://toolz.readthedocs.io and the full
`API Documentation `__
for more details.
%prep
%autosetup -n cytoolz-0.12.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cytoolz -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.12.1-1
- Package Spec generated