%global _empty_manifest_terminate_build 0
Name: python-pytest-trio
Version: 0.8.0
Release: 1
Summary: Pytest plugin for trio
License: MIT OR Apache-2.0
URL: https://github.com/python-trio/pytest-trio
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/13/08/056279526554c6c6e6ad6d4a479a338d14dc785ac30be8bdc6ca0153c1be/pytest-trio-0.8.0.tar.gz
BuildArch: noarch
Requires: python3-trio
Requires: python3-outcome
Requires: python3-pytest
%description
This is a pytest plugin to help you test projects that use `Trio
`__, a friendly library for concurrency
and async I/O in Python. For an overview of features, see our `manual
`__, or jump straight to the
`quickstart guide
`__.
%package -n python3-pytest-trio
Summary: Pytest plugin for trio
Provides: python-pytest-trio
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pytest-trio
This is a pytest plugin to help you test projects that use `Trio
`__, a friendly library for concurrency
and async I/O in Python. For an overview of features, see our `manual
`__, or jump straight to the
`quickstart guide
`__.
%package help
Summary: Development documents and examples for pytest-trio
Provides: python3-pytest-trio-doc
%description help
This is a pytest plugin to help you test projects that use `Trio
`__, a friendly library for concurrency
and async I/O in Python. For an overview of features, see our `manual
`__, or jump straight to the
`quickstart guide
`__.
%prep
%autosetup -n pytest-trio-0.8.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pytest-trio -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.8.0-1
- Package Spec generated