%global _empty_manifest_terminate_build 0
Name: python-spdx
Version: 2.5.1
Release: 1
Summary: SPDX license list database
License: CC0-1.0
URL: https://github.com/bbqsrc/spdx-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/bc/a405bbad6eabd62538ec047a3ab2294142606e516c676eddbefade70c375/spdx-2.5.1.tar.gz
BuildArch: noarch
%description
A Python module incorporating an interface to the SPDX license database.
This library serves purely as a holder for the database that can be
found on `the SPDX website `__.
To more easily query this database or detect licenses, consider using
something like
`spdx-lookup `__.
%package -n python3-spdx
Summary: SPDX license list database
Provides: python-spdx
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-spdx
A Python module incorporating an interface to the SPDX license database.
This library serves purely as a holder for the database that can be
found on `the SPDX website `__.
To more easily query this database or detect licenses, consider using
something like
`spdx-lookup `__.
%package help
Summary: Development documents and examples for spdx
Provides: python3-spdx-doc
%description help
A Python module incorporating an interface to the SPDX license database.
This library serves purely as a holder for the database that can be
found on `the SPDX website `__.
To more easily query this database or detect licenses, consider using
something like
`spdx-lookup `__.
%prep
%autosetup -n spdx-2.5.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-spdx -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 2.5.1-1
- Package Spec generated