%global _empty_manifest_terminate_build 0
Name: python-packaging
Version: 23.1
Release: 1
Summary: Core utilities for Python packages
License: Apache Software License
URL: https://pypi.org/project/packaging/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b9/6c/7c6658d258d7971c5eb0d9b69fa9265879ec9a9158031206d47800ae2213/packaging-23.1.tar.gz
BuildArch: noarch
%description
Reusable core utilities for various Python Packaging
`interoperability specifications `_.
This library provides utilities that implement the interoperability
specifications which have clearly one correct behaviour (eg: :pep:`440`)
or benefit greatly from having a single shared implementation (eg: :pep:`425`).
The ``packaging`` project includes the following: version handling, specifiers,
markers, requirements, tags, utilities.
%package -n python3-packaging
Summary: Core utilities for Python packages
Provides: python-packaging
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-packaging
Reusable core utilities for various Python Packaging
`interoperability specifications `_.
This library provides utilities that implement the interoperability
specifications which have clearly one correct behaviour (eg: :pep:`440`)
or benefit greatly from having a single shared implementation (eg: :pep:`425`).
The ``packaging`` project includes the following: version handling, specifiers,
markers, requirements, tags, utilities.
%package help
Summary: Development documents and examples for packaging
Provides: python3-packaging-doc
%description help
Reusable core utilities for various Python Packaging
`interoperability specifications `_.
This library provides utilities that implement the interoperability
specifications which have clearly one correct behaviour (eg: :pep:`440`)
or benefit greatly from having a single shared implementation (eg: :pep:`425`).
The ``packaging`` project includes the following: version handling, specifiers,
markers, requirements, tags, utilities.
%prep
%autosetup -n packaging-23.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-packaging -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 23.1-1
- Package Spec generated