%global _empty_manifest_terminate_build 0
Name: python-fpdf
Version: 1.7.2
Release: 1
Summary: Simple PDF generation for Python
License: LGPLv3+
URL: http://code.google.com/p/pyfpdf
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/37/c6/608a9e6c172bf9124aa687ec8b9f0e8e5d697d59a5f4fad0e2d5ec2a7556/fpdf-1.7.2.tar.gz
BuildArch: noarch
%description
PyFPDF is a library for PDF document generation under Python, ported
from PHP (see `FPDF `__ "Free"-PDF, a well-known
PDFlib-extension replacement with many examples, scripts and
derivatives).
Compared with other PDF libraries, PyFPDF is simple, small and
versatile, with advanced capabilities and easy to learn, extend and
maintain.
%package -n python3-fpdf
Summary: Simple PDF generation for Python
Provides: python-fpdf
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fpdf
PyFPDF is a library for PDF document generation under Python, ported
from PHP (see `FPDF `__ "Free"-PDF, a well-known
PDFlib-extension replacement with many examples, scripts and
derivatives).
Compared with other PDF libraries, PyFPDF is simple, small and
versatile, with advanced capabilities and easy to learn, extend and
maintain.
%package help
Summary: Development documents and examples for fpdf
Provides: python3-fpdf-doc
%description help
PyFPDF is a library for PDF document generation under Python, ported
from PHP (see `FPDF `__ "Free"-PDF, a well-known
PDFlib-extension replacement with many examples, scripts and
derivatives).
Compared with other PDF libraries, PyFPDF is simple, small and
versatile, with advanced capabilities and easy to learn, extend and
maintain.
%prep
%autosetup -n fpdf-1.7.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fpdf -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 1.7.2-1
- Package Spec generated