%global _empty_manifest_terminate_build 0 Name: python-typing-compat Version: 0.1.0 Release: 1 Summary: Python typing compatibility library License: Apache Software License URL: https://github.com/rossmacarthur/typing-compat Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c8/f3/47e8f5d02b190aa1d47ad0311f55873121b7a0728c30423ce56bf790232c/typing-compat-0.1.0.tar.gz BuildArch: noarch Requires: python3-typing %description

typing-compat

Python typing compatibility library

Build status Code style: black

In Python >=3.8 the `typing.get_origin` and `typing.get_args` functions are provided. This library aims to bring the identical behaviour of these functions to other versions of Python. ## Getting started ```bash pip install typing-compat ``` ## Usage ```python >>> from typing import List, Tuple, TypeVar >>> from typing_compat import get_args, get_origin >>> T = TypeVar('T') >>> tp = List[Tuple[T, T]][int] >>> get_args(tp) (typing.Tuple[int, int],) >>> get_origin(tp) ``` ## License This library is licensed under either of - Apache License, Version 2.0 ([LICENSE-APACHE](LICENSE-APACHE) or https://www.apache.org/licenses/LICENSE-2.0) - MIT License ([LICENSE-MIT](LICENSE-MIT) or https://opensource.org/licenses/MIT) at your option. %package -n python3-typing-compat Summary: Python typing compatibility library Provides: python-typing-compat BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-typing-compat

typing-compat

Python typing compatibility library

Build status Code style: black

In Python >=3.8 the `typing.get_origin` and `typing.get_args` functions are provided. This library aims to bring the identical behaviour of these functions to other versions of Python. ## Getting started ```bash pip install typing-compat ``` ## Usage ```python >>> from typing import List, Tuple, TypeVar >>> from typing_compat import get_args, get_origin >>> T = TypeVar('T') >>> tp = List[Tuple[T, T]][int] >>> get_args(tp) (typing.Tuple[int, int],) >>> get_origin(tp) ``` ## License This library is licensed under either of - Apache License, Version 2.0 ([LICENSE-APACHE](LICENSE-APACHE) or https://www.apache.org/licenses/LICENSE-2.0) - MIT License ([LICENSE-MIT](LICENSE-MIT) or https://opensource.org/licenses/MIT) at your option. %package help Summary: Development documents and examples for typing-compat Provides: python3-typing-compat-doc %description help

typing-compat

Python typing compatibility library

Build status Code style: black

In Python >=3.8 the `typing.get_origin` and `typing.get_args` functions are provided. This library aims to bring the identical behaviour of these functions to other versions of Python. ## Getting started ```bash pip install typing-compat ``` ## Usage ```python >>> from typing import List, Tuple, TypeVar >>> from typing_compat import get_args, get_origin >>> T = TypeVar('T') >>> tp = List[Tuple[T, T]][int] >>> get_args(tp) (typing.Tuple[int, int],) >>> get_origin(tp) ``` ## License This library is licensed under either of - Apache License, Version 2.0 ([LICENSE-APACHE](LICENSE-APACHE) or https://www.apache.org/licenses/LICENSE-2.0) - MIT License ([LICENSE-MIT](LICENSE-MIT) or https://opensource.org/licenses/MIT) at your option. %prep %autosetup -n typing-compat-0.1.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-typing-compat -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri Apr 21 2023 Python_Bot - 0.1.0-1 - Package Spec generated