%global _empty_manifest_terminate_build 0
Name: python-dash-bootstrap-components
Version: 1.4.1
Release: 1
Summary: Bootstrap themed components for use in Plotly Dash
License: Apache Software License
URL: https://dash-bootstrap-components.opensource.faculty.ai/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/56/ad/05d76ae657fe1dda77fae9e6b5b64e83e6b56259f3d47fb7ef9e4c3f0012/dash-bootstrap-components-1.4.1.tar.gz
BuildArch: noarch
Requires: python3-dash
Requires: python3-numpy
Requires: python3-pandas
%description
Dash Bootstrap Components
Bootstrap components for Plotly Dash
Explore the documentation ~
Report a bug ~
Request a feature
_dash-bootstrap-components_ is a library of [Bootstrap][bootstrap-homepage]
components for use with [Plotly Dash][dash-homepage], that makes it easier to
build consistently styled Dash apps with complex, responsive layouts.
## Installation
### PyPI
You can install _dash-bootstrap-components_ with `pip`:
```sh
pip install dash-bootstrap-components
```
### Anaconda
You can also install _dash-bootstrap-components_ with `conda` through the
conda-forge channel:
```sh
conda install -c conda-forge dash-bootstrap-components
```
## Quick start
To use _dash-bootstrap-components_ you must do two things:
- Link a Bootstrap v5 compatible stylesheet
- Incorporate _dash-bootstrap-components_ into your layout
### Linking a stylesheet
_dash-bootstrap-components_ doesn't come with CSS included. This is to give you
the freedom to use any Bootstrap v5 stylesheet of your choice. This means
however that in order for the components to be styled properly, you must link
to a stylesheet yourself.
For convenience, links to [BootstrapCDN][bootstrapcdn] for each theme are
available through the `themes` module, which can be used as follows:
```python
import dash
import dash_bootstrap_components as dbc
app = dash.Dash(external_stylesheets=[dbc.themes.BOOTSTRAP])
```
For more information on how to link local or external CSS, check out the
[Dash documentation][dash-docs-external].
### Build the layout
With CSS linked, you can start building your app's layout with our Bootstrap
components. See our [_documentation_][docs-components] for a full list of
available components.
## Contributing
We welcome contributions to _dash-bootstrap-components_. If you find a bug or
something is unclear please [submit a bug report][bug-report], if you have ideas
for new features please feel free to make a [feature request][feature-request].
If you would like to submit a pull request, please read our
[contributing guide][contribution-guide].
## Copyright and license
Code and documentation is copyright [Faculty Science Ltd.][faculty]
2018-2022, and released under the [Apache 2.0 license](./LICENSE.txt)
[dash-homepage]: https://dash.plot.ly/
[dash-docs-external]: https:/dash.plot.ly/external-resources
[bootstrap-homepage]: https://getbootstrap.com/
[dbc-repo]: https://github.com/facultyai/dash-bootstrap-components
[reactstrap-homepage]: https://reactstrap.github.io/
[docs-homepage]: https://dash-bootstrap-components.opensource.faculty.ai
[docs-components]: https://dash-bootstrap-components.opensource.faculty.ai/l/components
[bootstrapcdn]: https://www.bootstrapcdn.com/
[faculty]: https://faculty.ai
[bug-report]: https://github.com/facultyai/dash-bootstrap-components/issues/new?template=bug.md
[feature-request]: https://github.com/facultyai/dash-bootstrap-components/issues/new?template=feature.md
[contribution-guide]: https://github.com/facultyai/dash-bootstrap-components/blob/main/.github/CONTRIBUTING.md
%package -n python3-dash-bootstrap-components
Summary: Bootstrap themed components for use in Plotly Dash
Provides: python-dash-bootstrap-components
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dash-bootstrap-components
Dash Bootstrap Components
Bootstrap components for Plotly Dash
Explore the documentation ~
Report a bug ~
Request a feature
_dash-bootstrap-components_ is a library of [Bootstrap][bootstrap-homepage]
components for use with [Plotly Dash][dash-homepage], that makes it easier to
build consistently styled Dash apps with complex, responsive layouts.
## Installation
### PyPI
You can install _dash-bootstrap-components_ with `pip`:
```sh
pip install dash-bootstrap-components
```
### Anaconda
You can also install _dash-bootstrap-components_ with `conda` through the
conda-forge channel:
```sh
conda install -c conda-forge dash-bootstrap-components
```
## Quick start
To use _dash-bootstrap-components_ you must do two things:
- Link a Bootstrap v5 compatible stylesheet
- Incorporate _dash-bootstrap-components_ into your layout
### Linking a stylesheet
_dash-bootstrap-components_ doesn't come with CSS included. This is to give you
the freedom to use any Bootstrap v5 stylesheet of your choice. This means
however that in order for the components to be styled properly, you must link
to a stylesheet yourself.
For convenience, links to [BootstrapCDN][bootstrapcdn] for each theme are
available through the `themes` module, which can be used as follows:
```python
import dash
import dash_bootstrap_components as dbc
app = dash.Dash(external_stylesheets=[dbc.themes.BOOTSTRAP])
```
For more information on how to link local or external CSS, check out the
[Dash documentation][dash-docs-external].
### Build the layout
With CSS linked, you can start building your app's layout with our Bootstrap
components. See our [_documentation_][docs-components] for a full list of
available components.
## Contributing
We welcome contributions to _dash-bootstrap-components_. If you find a bug or
something is unclear please [submit a bug report][bug-report], if you have ideas
for new features please feel free to make a [feature request][feature-request].
If you would like to submit a pull request, please read our
[contributing guide][contribution-guide].
## Copyright and license
Code and documentation is copyright [Faculty Science Ltd.][faculty]
2018-2022, and released under the [Apache 2.0 license](./LICENSE.txt)
[dash-homepage]: https://dash.plot.ly/
[dash-docs-external]: https:/dash.plot.ly/external-resources
[bootstrap-homepage]: https://getbootstrap.com/
[dbc-repo]: https://github.com/facultyai/dash-bootstrap-components
[reactstrap-homepage]: https://reactstrap.github.io/
[docs-homepage]: https://dash-bootstrap-components.opensource.faculty.ai
[docs-components]: https://dash-bootstrap-components.opensource.faculty.ai/l/components
[bootstrapcdn]: https://www.bootstrapcdn.com/
[faculty]: https://faculty.ai
[bug-report]: https://github.com/facultyai/dash-bootstrap-components/issues/new?template=bug.md
[feature-request]: https://github.com/facultyai/dash-bootstrap-components/issues/new?template=feature.md
[contribution-guide]: https://github.com/facultyai/dash-bootstrap-components/blob/main/.github/CONTRIBUTING.md
%package help
Summary: Development documents and examples for dash-bootstrap-components
Provides: python3-dash-bootstrap-components-doc
%description help
Dash Bootstrap Components
Bootstrap components for Plotly Dash
Explore the documentation ~
Report a bug ~
Request a feature
_dash-bootstrap-components_ is a library of [Bootstrap][bootstrap-homepage]
components for use with [Plotly Dash][dash-homepage], that makes it easier to
build consistently styled Dash apps with complex, responsive layouts.
## Installation
### PyPI
You can install _dash-bootstrap-components_ with `pip`:
```sh
pip install dash-bootstrap-components
```
### Anaconda
You can also install _dash-bootstrap-components_ with `conda` through the
conda-forge channel:
```sh
conda install -c conda-forge dash-bootstrap-components
```
## Quick start
To use _dash-bootstrap-components_ you must do two things:
- Link a Bootstrap v5 compatible stylesheet
- Incorporate _dash-bootstrap-components_ into your layout
### Linking a stylesheet
_dash-bootstrap-components_ doesn't come with CSS included. This is to give you
the freedom to use any Bootstrap v5 stylesheet of your choice. This means
however that in order for the components to be styled properly, you must link
to a stylesheet yourself.
For convenience, links to [BootstrapCDN][bootstrapcdn] for each theme are
available through the `themes` module, which can be used as follows:
```python
import dash
import dash_bootstrap_components as dbc
app = dash.Dash(external_stylesheets=[dbc.themes.BOOTSTRAP])
```
For more information on how to link local or external CSS, check out the
[Dash documentation][dash-docs-external].
### Build the layout
With CSS linked, you can start building your app's layout with our Bootstrap
components. See our [_documentation_][docs-components] for a full list of
available components.
## Contributing
We welcome contributions to _dash-bootstrap-components_. If you find a bug or
something is unclear please [submit a bug report][bug-report], if you have ideas
for new features please feel free to make a [feature request][feature-request].
If you would like to submit a pull request, please read our
[contributing guide][contribution-guide].
## Copyright and license
Code and documentation is copyright [Faculty Science Ltd.][faculty]
2018-2022, and released under the [Apache 2.0 license](./LICENSE.txt)
[dash-homepage]: https://dash.plot.ly/
[dash-docs-external]: https:/dash.plot.ly/external-resources
[bootstrap-homepage]: https://getbootstrap.com/
[dbc-repo]: https://github.com/facultyai/dash-bootstrap-components
[reactstrap-homepage]: https://reactstrap.github.io/
[docs-homepage]: https://dash-bootstrap-components.opensource.faculty.ai
[docs-components]: https://dash-bootstrap-components.opensource.faculty.ai/l/components
[bootstrapcdn]: https://www.bootstrapcdn.com/
[faculty]: https://faculty.ai
[bug-report]: https://github.com/facultyai/dash-bootstrap-components/issues/new?template=bug.md
[feature-request]: https://github.com/facultyai/dash-bootstrap-components/issues/new?template=feature.md
[contribution-guide]: https://github.com/facultyai/dash-bootstrap-components/blob/main/.github/CONTRIBUTING.md
%prep
%autosetup -n dash-bootstrap-components-1.4.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dash-bootstrap-components -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 1.4.1-1
- Package Spec generated