%global _empty_manifest_terminate_build 0
Name: python-pgeocode
Version: 0.4.0
Release: 1
Summary: Approximate geocoding
License: BSD
URL: https://pypi.org/project/pgeocode/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/19/49/d2e5703ec197048f652203fc44c50aa47b9dc7c0fc0cecc046bbe5ceec2f/pgeocode-0.4.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-thefuzz
%description
|pypi| |condaforge| |rdfd| |GHactions|
Postal code geocoding and distance calculations
pgeocode is a Python library for high performance off-line querying of GPS coordinates, region name and municipality name
from postal codes. Distances between postal codes as well as general
distance queries are also supported.
The used `GeoNames `_ database includes postal codes for 83 countries.
Currently, only queries within the same country are supported.
For additional documentation see `pgeocode.readthedocs.io `_.
%package -n python3-pgeocode
Summary: Approximate geocoding
Provides: python-pgeocode
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pgeocode
|pypi| |condaforge| |rdfd| |GHactions|
Postal code geocoding and distance calculations
pgeocode is a Python library for high performance off-line querying of GPS coordinates, region name and municipality name
from postal codes. Distances between postal codes as well as general
distance queries are also supported.
The used `GeoNames `_ database includes postal codes for 83 countries.
Currently, only queries within the same country are supported.
For additional documentation see `pgeocode.readthedocs.io `_.
%package help
Summary: Development documents and examples for pgeocode
Provides: python3-pgeocode-doc
%description help
|pypi| |condaforge| |rdfd| |GHactions|
Postal code geocoding and distance calculations
pgeocode is a Python library for high performance off-line querying of GPS coordinates, region name and municipality name
from postal codes. Distances between postal codes as well as general
distance queries are also supported.
The used `GeoNames `_ database includes postal codes for 83 countries.
Currently, only queries within the same country are supported.
For additional documentation see `pgeocode.readthedocs.io `_.
%prep
%autosetup -n pgeocode-0.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pgeocode -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.4.0-1
- Package Spec generated